HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Client can recieve mail but not send emails. (http://www.howtoforge.com/forums/showthread.php?t=22257)

DaRKNeSS666NL 12th April 2008 20:55

Client can recieve mail but not send emails.
 
Hello all,
Again a problem with my server. The situation is like this:

I have setup my own server here at home. Its in my home network. I used the perfect setup with Ubuntu 7.10.
I have setup an domain for our band with email users. I CAN sent and receive email without any problems all is working fine. So postfix is running nicely for me in my network at home.

However if any of the other band members are trying to use their email, outside of my network, they can receive email but they cant sent any out.

I have tryed it my self from outside my network and indeed its not sending emails out. I am getting the following error (in dutch)
Code:

Het maken van een verbinding met de server
is mislukt. Account `www.dcs-online.nl`server`www.dcs-online.nl`protocol (:SMTP,poort : 25,beveiligd
(ssl):nee, socketsfout,10060 foutnummer x800cccoe

Rougly translated
Code:

cannot connect to server. Account `www.dcs-online.nl`server`www.dcs-online.nl`protocol (:SMTP,poort : 25,secured
(ssl):NO, socketsfout,10060 foutnummer x800cccoe

Yes authenticate smtp is enabled in outlook express. And is using the same as pop3.

Must I forward some other ports in my router? I have forwarded the following
80, 81, 25, 2525, 110, 20 and 21

I am confused can someone point to the solution please.

daveb 12th April 2008 22:31

maybe your isp blocks port 25. If thats the case you can config postfix to use port 587. http://www.howtoforge.com/forums/sho...stfix+port+587

DaRKNeSS666NL 12th April 2008 23:02

@daveb

Thanks for thinking along with me. I know for a fact that my isp is blocking port 25. Thats why I forwarded port 2525 and I am using rollernet for relaying.

I found in the provided link however one thing I am going to try I was using in the master.cf
Code:

smtp      inet  n      -      -      -      -      smtpd
2525      inet  n      -      n      -      -      smtpd

That I have changed to
Code:

smtp      inet  n      -      -      -      -      smtpd
2525      inet  n      -      -      -      -      smtpd

Like Falko suggested in that thread

I must go to an outside connection however to know of its working.
I will let you know

daveb 12th April 2008 23:16

Well looks like its working. just make sure you have them set their email clients to use port 2525.

Code:

david@david:~$ telnet www.dcs-online.nl 2525
Trying 84.31.236.18...
Connected to dcs-online.nl.
Escape character is '^]'.
220 server1.dcs-online.nl ESMTP Postfix (Ubuntu)
ehlo server1.doc-online.nl
250-server1.dcs-online.nl
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.


DaRKNeSS666NL 14th April 2008 21:19

I tested it today on an outside connexion and indeed its sending the mails.
I think its okee now wil ask the other guys of the band to try it at their side.

Will let you know what happens.


All times are GMT +2. The time now is 00:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.