HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=19)
-   -   Ftp (http://www.howtoforge.com/forums/showthread.php?t=22131)

kassie 9th April 2008 06:43

Ftp
 
Hi All,

Everything working great. My FTP is working, but very slow to open the directories and bring up the welcome message when logging in. When i transfer file it takes long to start the process, but as soon as the transfer starts it is quick.

Any suggestions

I Use ISPConfig 2.2.21 on Ubuntu 7.04 Perfect Setup

kristaps 10th April 2008 12:35

Your problem is related to active passive mode probably.

Add the following
“PassivePorts 5000 5500”
line after “Port 21”
in “vi /etc/proftpd.conf”

And in ispconfig firewall rules open ports “name:FTP Pasive range:5000:5500 prot:tcp active:yes”

Restart ftp “/etc/init.d/proftpd restart”

kristaps 10th April 2008 12:53

More:

Add
IdentLookups off
ServerIdent on "FTP Server ready."

after
DefaultRoot ~

Disable:
# Bar use of SITE CHMOD by default
# <Limit SITE_CHMOD>
# DenyAll
# </Limit>

# Include /etc/proftpd_ispconfig.conf

kassie 13th April 2008 13:45

Where do i add these lines???

Sorry... Newbie

falko 14th April 2008 15:16

Quote:

Originally Posted by kassie
Where do i add these lines???

In /etc/proftpd.conf.

kristaps 14th April 2008 15:43

Sorry: e-mail server went down :(
Understand what you are doing otherwise You can make security hole.
Read proftpd manual – my post is pointer to right answer!


All times are GMT +2. The time now is 16:38.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.