HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Strange problem with Firefox and PHP after update of ISPconfig (http://www.howtoforge.com/forums/showthread.php?t=22043)

heinerlamprecht 5th April 2008 17:40

Strange problem with Firefox and PHP after update of ISPconfig
 
Hi,

I just made an update of ISPconfig (from 2.2.12 to 2.2.21). Now I encounter quite a strange problem with Firefox on Linux (not with other browsers, as well as FF on Windows): If I request the entrypage of my website (http://www.heiner-lamprecht.net/), Firefox offers me to save the page to disk, and the php source is saved. Other browsers can show the real page.

The problem only effects the entry-page. If I enter the URL of some other php-page, it works.

Honestly, I don't understand this issue. I know, it's strange but maybe someone has an idea, what to do.


Thanks,


Heiner

heinerlamprecht 5th April 2008 17:56

It looks as if it was a caching problem in Firefox. After the update, I had to edit /etc/apache2/conf.d/php5.conf, because the path to php was wrong there. And I did that after the first try with Firefox. After that it worked for the other browsers, but not for this caching friend :(


Heiner

shanta 9th October 2008 18:29

php saving problem
 
I have had this problem on a Linux Xubuntu client. Both of my servers and All browsers. Some pages such as this site seem to work fine. Ispconfig seems to work but the user mail programs and any other installed PHP scripts seems to be saved instead of executed.

Domains have the PHP scripts option clicked.

How do I fix this problem?

Thanks
Shanta

falko 10th October 2008 14:23

Which distribution are you using? What's in Vhosts_ispconfig.conf?


All times are GMT +2. The time now is 03:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.