HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ispconfig postconf sasl smtpd mail not working (http://www.howtoforge.com/forums/showthread.php?t=21973)

vinodadhikary 4th April 2008 02:18

ispconfig postconf sasl smtpd mail not working
 
Hi I followed Falko's "Fedora 8 Server Setup: LAMP, Email, DNS, FTP, ISPConfig"

My mail is not working. I have my own DNS server and I do have my host record set as A as well as MX. here is my iptables since it doesn't have the port open but I am really confused because ispconfig shows that my servers are running.

Code:

:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Firewall-1-INPUT - [0:0]
-A INPUT -j RH-Firewall-1-INPUT
-A RH-Firewall-1-INPUT -i lo -j ACCEPT
-A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 110 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 81 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 21 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 25 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 53 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 53 -j ACCEPT

I've had problems with this mail for a while now, I tried figuring out myself but no luck yet. Gurus, help please.

till 4th April 2008 16:39

Please have a look into your maillog. Which messages or errors appear when you send a email?

vinodadhikary 5th April 2008 03:08

actually I uninstalled postfix and installed again according to falko's perfect server setup for fc8. Now I just figured out that when I perform
Code:

telnet localhost 25
I get the desired result. but when I do


Code:

telnet vibhas.webinformatix.com
I get:

Quote:

Connected to vibhas.
Escape character is '^]'.
ehlo vibhas
Connection closed by foreign host.
am I missing something?

vinodadhikary 5th April 2008 21:22

okay got this to work after adding my networks ip to the mynetworks. the new problem is that
Quote:

Apr 5 15:10:38 wiplds postfix/smtpd[17922]: connect from netcom1.telgam.pl[88.220.133.202]
Apr 5 15:10:39 wiplds postfix/smtpd[17922]: NOQUEUE: reject: RCPT from netcom1.telgam.pl[88.220.133.202]: 554 5.7.1 <provisorship@webinformatix.com>: Relay access denied; from=<unsnobbi_1989@SEMITORRDIST.COM> to=<provisorship@webinformatix.com> proto=ESMTP helo=<netcom1.telgam.pl>
Apr 5 15:10:39 wiplds postfix/smtpd[17922]: disconnect from netcom1.telgam.pl[88.220.133.202]

falko 5th April 2008 21:58

Please enable "Server requires authentication" in your email client.

vinodadhikary 5th April 2008 23:32

I have that set already in my email client. I believe you are referring to that. I restarted my machine now my maillog is:
Quote:

Apr 5 17:11:15 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/pickup pid 3053 exit status 1
Apr 5 17:11:15 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/pickup: bad command startup -- throttling
Apr 5 17:11:15 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/qmgr pid 3054 exit status 1
Apr 5 17:11:15 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Apr 5 17:12:05 wiplds postfix/smtpd[3067]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:12:06 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/smtpd pid 3067 exit status 1
Apr 5 17:12:06 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 5 17:12:15 wiplds postfix/pickup[3070]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:12:15 wiplds postfix/qmgr[3071]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:12:16 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/pickup pid 3070 exit status 1
Apr 5 17:12:16 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/pickup: bad command startup -- throttling
Apr 5 17:12:16 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/qmgr pid 3071 exit status 1
Apr 5 17:12:16 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Apr 5 17:13:06 wiplds postfix/smtpd[3083]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:13:07 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/smtpd pid 3083 exit status 1
Apr 5 17:13:07 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 5 17:13:16 wiplds postfix/pickup[3086]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:13:16 wiplds postfix/qmgr[3087]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:13:17 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/pickup pid 3086 exit status 1
Apr 5 17:13:17 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/pickup: bad command startup -- throttling
Apr 5 17:13:17 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/qmgr pid 3087 exit status 1
Apr 5 17:13:17 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Apr 5 17:14:07 wiplds postfix/smtpd[3100]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:14:08 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/smtpd pid 3100 exit status 1
Apr 5 17:14:08 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 5 17:14:17 wiplds postfix/pickup[3103]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:14:17 wiplds postfix/qmgr[3104]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:14:18 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/pickup pid 3103 exit status 1
Apr 5 17:14:18 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/pickup: bad command startup -- throttling
Apr 5 17:14:18 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/qmgr pid 3104 exit status 1
Apr 5 17:14:18 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Apr 5 17:15:08 wiplds postfix/smtpd[3116]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
Apr 5 17:15:09 wiplds postfix/master[2300]: warning: process /usr/libexec/postfix/smtpd pid 3116 exit status 1
Apr 5 17:15:09 wiplds postfix/master[2300]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

vinodadhikary 6th April 2008 03:16

well i've got that to working. I created a local-host-names and actually had to add a dummy host within ispconfig so that the local-host-names be populated.

Quote:

Apr 5 21:00:09 wiplds postfix/anvil[30510]: statistics: max connection rate 1/60s for (smtp:76.11.235.201) at Apr 5 20:54:16
Apr 5 21:00:09 wiplds postfix/anvil[30510]: statistics: max connection count 1 for (smtp:76.11.235.201) at Apr 5 20:54:16
Apr 5 21:00:09 wiplds postfix/anvil[30510]: statistics: max cache size 2 at Apr 5 20:54:44
Apr 5 21:00:56 wiplds postfix/smtpd[30621]: connect from dyn-83-156-158-29.ppp.tiscali.fr[83.156.158.29]
Apr 5 21:00:57 wiplds postfix/smtpd[30621]: NOQUEUE: reject: RCPT from dyn-83-156-158-29.ppp.tiscali.fr[83.156.158.29]: 550 5.1.1 <mniaceous@webinformatix.com>: Recipient address rejected: User unknown in local recipient table; from=<Sclassification@jstor.org> to=<mniaceous@webinformatix.com> proto=SMTP helo=<acer19b694409a>
Apr 5 21:00:57 wiplds postfix/smtpd[30621]: lost connection after RCPT from dyn-83-156-158-29.ppp.tiscali.fr[83.156.158.29]
Apr 5 21:00:57 wiplds postfix/smtpd[30621]: disconnect from dyn-83-156-158-29.ppp.tiscali.fr[83.156.158.29]
Apr 5 21:04:17 wiplds postfix/anvil[30623]: statistics: max connection rate 1/60s for (smtp:83.156.158.29) at Apr 5 21:00:56
Apr 5 21:04:17 wiplds postfix/anvil[30623]: statistics: max connection count 1 for (smtp:83.156.158.29) at Apr 5 21:00:56
Apr 5 21:04:17 wiplds postfix/anvil[30623]: statistics: max cache size 1 at Apr 5 21:00:56

vinodadhikary 6th April 2008 05:23

funny thing, I got this to work but I really dont' know how. I added the local-host-names to mydestination in /etc/postfix/main.cf and restarted postfix after doing a postfix reload. Its working!!! Now the new problem is I am trying to send email to my hotmail account with the mail myaddress@hotmail.com. the maillog doesn't show anything wrong but I don't see any new emails in my hotmail account and when I try to send a message from hotmail to my domain account myaddress@mydomain.com, no error so far but don't see anything in my mailbox.

I tried connecting to port 25 from external network but the connection times out and could not connect. I have checked my iptables and called my isp to see if they have blocked it, but no they haven't.

vinodadhikary 6th April 2008 16:09

all solved. thanks you guys.


All times are GMT +2. The time now is 13:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.