HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig crashes with new SSL using same server name. (http://www.howtoforge.com/forums/showthread.php?t=21615)

knotpc 22nd March 2008 20:46

ISPConfig crashes with new SSL using same server name.
 
Sorry to post this. I searched and did not find what I was looking for.

I am running a new install of ISPConfig on Debian 4.0. During setup I provided the box a name in all setups. Initially ISPConfig was set to https://www.mydomainname.com:81. Which worked great. I then setup my first site http://www.mydomainname.com/, same as the ISP domain. I then added an SSL cert from Godaddy to the domain, using the ISPConfig portal.

The domain http://www.mydomainname.com and https://www.mydomainname.com both load correctly. However the https://www.mydomainname.com:81 no longer works. So the portal is not accessable.

I followed the instructions to use http by editing the http.conf file and editing the config.php file. I then restarted the ISPconfig server. This allows me to use the portal.

I beleive the portal not working was due to a mismatch in the system with https://www.mydomainname.com having a valid SSL but port 81 having its own.

I really want to use the portal with secure SSL and my new certificate. This is where I am stumped. I beleive some edits need to be made to the system, but I am not sure where to start. I thought of creating and "admin" folder like https://www.mydomainname.com/admin then creating a symbolic link to the ISPConfig index.php. But I think that I would still need to edit the system settings to make this work and I am not sure which ones to mess with.

If any of you have a suggestion on how to get this to work correctly I would really appreciate it.

Thanks.

Clint.

daveb 22nd March 2008 21:00

did you replace the ssl-pvt.key file also for your ispconfig control panel that goes with your ssl.crt?

bswinnerton 23rd March 2008 03:08

Did you install the certificate manually or through ISPConfig?

knotpc 5th April 2008 23:11

DaveB,

Sorry it took me a while to post back. I had to get some other work done and this project was put on hold for a couple of days.

In answer to your question no I did not. I installed the cert using the ISPCONFIG control panel for the website knotpc.com.

Would I simply need to rename then copy the www.knotpc.com SSL cert.key to the ISPCONFIG /httpd/conf/ssl.key to fix the issue?

Thanks for your ideas on this. Not sure why the ssl for port 81 does not work.

daveb 5th April 2008 23:54

If you installed the cert using the ispconfig control panel for the website knotpc.com and that site is working properly ssl in all. And you want to use the same cert for your ispconfig control panel at knotpc.com:81 you would need to copy your crt and key to your ispconfig apache ssl folders. be sure to rename then server.crt and server.key so at your next ispconfig update you wont have to redo anything.

Code:

cp /var/www/web#/ssl/www.yoursite.com.key /root/ispconfig/httpd/conf/ssl.key/server.key
Code:

cp /var/www/web#/ssl/www.yoursite.com.crt /root/ispconfig/httpd/conf/ssl.crt/server.crt
then restart ispconfig
Code:

/etc/init.d/ispconfig_server restart

knotpc 6th April 2008 19:55

Thanks
 
Thanks I made the change to the files. Now to find the thread on how to change the httpd_conf file and the associated ISPconfig file so that I can get the control panel back to https://www.myserver.com:81


All times are GMT +2. The time now is 08:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.