HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Unable to send/recieve E-mail (http://www.howtoforge.com/forums/showthread.php?t=2158)

phantomk 19th January 2006 23:15

Unable to send/recieve E-mail
 
These are the logs when I send a message and I check for messages
Code:

Jan 19 16:05:31 server postfix/smtpd[21126]: connect from cat.XXX.XXX
Jan 19 16:05:31 server postfix/smtpd[21126]: AD3CB41BC036: client=cat.XXX.XXX
Jan 19 16:05:31 server postfix/cleanup[21134]: AD3CB41BC036: message-id=<43D00DB1.2050700@XXX.XXX>
Jan 19 16:05:32 server postfix/nqmgr[20738]: AD3CB41BC036: from=<phantomk@XXX.XXX>, size=751, nrcpt=1 (queue active)
Jan 19 16:05:32 server postfix/local[21408]: AD3CB41BC036: to=<phantomk@server.XXX.XXX>, orig_to=<phantomk@XXX.XXX>, relay=local, delay=1, status=sent (maildir)
Jan 19 16:05:32 server postfix/smtpd[21126]: disconnect from cat.XXX.XXX
Jan 19 16:06:19 server ipop3d[10887]: pop3s SSL service init from 199.243.20.118
Jan 19 16:06:22 server ipop3d[10887]: Auth user=phantomk host=XXX.XXX nmsgs=0/0
Jan 19 16:06:22 server ipop3d[10887]: Logout user=phantomk host=XXX.XXX nmsgs=0 ndele=0

It says the message has been delievered, and it has I can see it in the Maildir folder, but I am unable to retrieve the message :S

I am useing the http://www.howtoforge.com/perfect_setup_fedora_core_3 guide as reference for my CentOS 3 setup.

I am also unable to recieve the e-mail unless I chmod the folders to 777, even though the user has ownership of the folders.

phantomk 19th January 2006 23:18

This is the message I get if I don't chmod to 777
Code:

Jan 19 16:04:02 server postfix/local[21408]: D1E9C41BC036: to=<phantomk@server.XXX.XXX>, orig_to=<test@XXX.XXX>, relay=local, delay=0, status=bounced (maildir delivery failed: create /home/phantomk/Maildir/tmp/1137708241.P21408.server.XXX.XXX: Permission denied)

falko 20th January 2006 06:47

You're using ipop3d which uses the mbox format, not Maildir. So you should either have Postfix deliver to mbox, or you install a POP3/IMAP daemon that uses Maildir (e.g. Courier or Dovecot).

If you want to stick with Maildir, then please post the output of
Code:

ls -la /home
ls -la /home/phantomk
ls -la /home/phantomk/Maildir



All times are GMT +2. The time now is 16:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.