HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   debian postfix mail problem (http://www.howtoforge.com/forums/showthread.php?t=2144)

stlshawn 19th January 2006 06:35

debian postfix mail problem
 
I have a site called troop4051.org and it is at 24.182.139.75. I ran through the perfect Debian setup, and i believe i screwed up with the email again (yes, i've been down this road before, and didn't fix it)


So, here's what i get when i try to login with outlook express using the ip address as the server.

Code:

There was a problem logging onto your mail server. Your User Name was rejected. Account: 'mail.troop4051.org', Server: '24.182.139.75', Protocol: POP3, Server Response: '-ERR Unknown AUTHORIZATION state command', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC91
When i change the server name to "mail.troop4051.org" i get this message...

Code:

The host 'mail.troop4051.org' could not be found. Please verify that you have entered the server name correctly. Account: 'mail.troop4051.org', Server: 'mail.troop4051.org', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 11004, Error Number: 0x800CCC0D
I assume that the second one means that my server does not know that it is mail.troop4051.org, and I really don't know how would i change that. I'll have to check with zoneedit to see if i have that all pointing the right places.

i have "deselected" the maildir check in ispconfig, but i'm still stuck.

There must be something i'm overlooking. Any idea where i should start looking.

Here's what's in netstat -tap gives me.
Code:


Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address          Foreign Address        State      PID/Program name
tcp        0      0 *:imaps                *:*                    LISTEN    1868/inetd
tcp        0      0 *:pop3s                *:*                    LISTEN    1868/inetd
tcp        0      0 localhost.localdo:mysql *:*                    LISTEN    1921/mysqld
tcp        0      0 *:pop3                  *:*                    LISTEN    1868/inetd
tcp        0      0 *:imap2                *:*                    LISTEN    1868/inetd
tcp        0      0 *:81                    *:*                    LISTEN    2109/ispconfig_http
tcp        0      0 *:ftp                  *:*                    LISTEN    2279/proftpd: (acce
tcp        0      0 www.troop4051.or:domain *:*                    LISTEN    2266/named
tcp        0      0 www.spiritedcomp:domain *:*                    LISTEN    2266/named
tcp        0      0 serv1.arwenspets:domain *:*                    LISTEN    2266/named
tcp        0      0 localhost.locald:domain *:*                    LISTEN    2266/named
tcp        0      0 *:smtp                  *:*                    LISTEN    25011/master
tcp        0      0 localhost.localdoma:953 *:*                    LISTEN    2266/named
tcp6      0      0 *:www                  *:*                    LISTEN    2140/apache2
tcp6      0      0 *:ssh                  *:*                    LISTEN    2074/sshd
tcp6      0      0 *:smtp                  *:*                    LISTEN    25011/master
tcp6      0      0 ip6-localhost:953      *:*                    LISTEN    2266/named
tcp6      0      0 *:https                *:*                    LISTEN    2140/apache2
tcp6      0      0 24-182-139-77.stati:ssh 24-182-139-74.sta:33132 ESTABLISHED25745/0

I downloaded the webmail program, but i have done nothing to configure it. Should i do something to configure that before it's usable? Right now it won't let me log in at all.

sorry, now i'm confusing myself :confused:


OK, so to clarify,
I don't know if mail works at all, because i can't log in using outlook express or the webmail program. The webmail program just says i can't log in using the names and passwords provided. I have tried variations on the names (boo, boo@troop4051.org, web3_boo, web3_boo@troop4051) and none seem to work.

Does anyone know a thread or something i could read like "the elementary guide to setting up email in ispconfig".

Any help would be appreciated, and sorry about all the questions at once.

themachine 19th January 2006 07:03

The first problem is that the subdomain "mail" doesn't exist:


Code:

# nslookup mail.troop4051.org
Server:        10.1.2.170
Address:        10.1.2.170#53

** server can't find mail.troop4051.org: NXDOMAIN


You need to create this subdomain in your DNS Control Panel or Zone file. It looks like you have an issue with authentication... (obviously)... but in order to trouble shoot I'll need the output of the server's mail log. On Debian this should be obtained like so

Code:

# tail -n100 /var/log/mail.log
This will give you the last 100 lines from the log. Run this command just after trying to authenticate (i.e. send mail and login to webmail) and then post this log to the forum.

falko 19th January 2006 07:46

Quote:

Originally Posted by stlshawn
OK, so to clarify,
I don't know if mail works at all, because i can't log in using outlook express or the webmail program. The webmail program just says i can't log in using the names and passwords provided. I have tried variations on the names (boo, boo@troop4051.org, web3_boo, web3_boo@troop4051) and none seem to work.

The username you have to use in Outlook Express is web3_boo; in Uebimiau you must an email address associated to that user, e.g. web3_boo@troop4051.org or boo@troop4051.org.
If that doesn't work, try to restart inetd:
Code:

/etc/init.d/inetd restart

stlshawn 21st January 2006 02:55

mail server ip
 
OK, so i'm now in "zoneedit.com"'s site, and i'm going to add an A record for mail.troop4051.org. The question is do i use the main IP for the server (24.182.139.77) or the ip for the site itself (24.182.139.75).

Also,
In ISPConfig's software, do i add it under "dns records > troop4051.org > (records tab)" then under the A record, and the MX record, or just the MX record?

uebimiau seems to still not want to let me log in when i just put these variations in ISPConfig's software, but i have not edited zoneedit's info yet.

And Finally,
Under "management > Server > Settings > DNS (tab)" , should i put in a real DNS server, or should i use itself (24.182.139.77)? And, should i check the "Default NX" box?

Sorry, but i keep editing this post,,,,,, This is going to seem a very simplistic question, but in a different post, i read that the mailbox was not created until a mail was sent to the user, how would one send a mail to someone in a non-existant server (unless i'm supposed to from like yahoo mail or somewhere). I know that in slackware, it can be done using "pine", but i don't believe i have this in debian.

Thanks for any help, you linux people rock!

Shawn (green with envy for your knowledge) :D .

falko 21st January 2006 08:09

Quote:

Originally Posted by stlshawn
OK, so i'm now in "zoneedit.com"'s site, and i'm going to add an A record for mail.troop4051.org. The question is do i use the main IP for the server (24.182.139.77) or the ip for the site itself (24.182.139.75).

It doesn't matter, as long as the IP address is on the same server and a public one.

Quote:

Originally Posted by stlshawn
Also,
In ISPConfig's software, do i add it under "dns records > troop4051.org > (records tab)" then under the A record, and the MX record, or just the MX record?

Don't use ISPConfig's DNS Manager for this domain because zonedit.com's name servers are authoritative for this domain!

Quote:

Originally Posted by stlshawn
And Finally,
Under "management > Server > Settings > DNS (tab)" , should i put in a real DNS server, or should i use itself (24.182.139.77)? And, should i check the "Default NX" box?

See above.

Quote:

Originally Posted by stlshawn
This is going to seem a very simplistic question, but in a different post, i read that the mailbox was not created until a mail was sent to the user, how would one send a mail to someone in a non-existant server (unless i'm supposed to from like yahoo mail or somewhere). I know that in slackware, it can be done using "pine", but i don't believe i have this in debian.

Let's say you have a user web1_test with the email address test@troop4051.org, and it has been created by ISPConfig. Your server has the IP address 24.182.139.77. So in your email client (e.g. Outlook Express, Thunderbird) you use 24.182.139.77 as SMTP- and POP3-server, specify web1_test as user and his password. Then you can use this account to send an email from test@troop4051.org to himself.

themachine 21st January 2006 18:05

Quote:

how would one send a mail to someone in a non-existant server (unless i'm supposed to from like yahoo mail or somewhere). I know that in slackware, it can be done using "pine", but i don't believe i have this in debian.

You can simply use the command 'mail <username>' and you'll be prompted for "Subject" -> hit enter -> type your message -> hit enter -> hit enter.... and you should be golden.

stlshawn 24th January 2006 04:59

still nothing, any ideas?
 
OK, i changed the settings in "management > Server > Settings > DNS (tab)" , and put in the zoneedit dns servers. I added the "A" record for mail.troop4051.org, and the MX record at Zoneedit.

now i can ping mail.troop4051.org, and it gives me the correct ip address of the server (24.182.139.75).

I also changed the settings in ISP Manager > troop4051.org > Basis (tab) , I unchecked "Create DNS:" and "Create DNS-MX:".

Now, i still cannot check email via outlook, i have changed the server settings to use 24.182.139.77 as SMTP- and POP3-server. I still cannot log in however.

When i putty into the machine, and login as web3_boo, it shows that there is mail waiting to be read (thanks themachine for the advice on how to use the mail command line, but i'm still not sure how to put text in the mail body).

I am also still not able to login with Uebimiau.

I'm not sure what i'm doing wrong, i did recreate the server last week because i was having this problem, and i thought i screwed up the installation process the first time. I really don't think i screwed it up this time, or maybe i did, but did the same exact thing i did wrong last time.

Any ideas? Any clue where i should be looking? I'm at such a loss.:confused:

falko 24th January 2006 09:36

Quote:

Originally Posted by stlshawn
OK, i changed the settings in "management > Server > Settings > DNS (tab)" , and put in the zoneedit dns servers. I added the "A" record for mail.troop4051.org, and the MX record at Zoneedit.

You misunderstood me. You can completely delete the troop4051.org zone from ISPConfig's DNS Manager because this domain is handled by the name servers ns2.zoneedit.com and ns3.zoneedit.com.

Quote:

Originally Posted by stlshawn
Now, i still cannot check email via outlook, i have changed the server settings to use 24.182.139.77 as SMTP- and POP3-server. I still cannot log in however.

When i putty into the machine, and login as web3_boo, it shows that there is mail waiting to be read (thanks themachine for the advice on how to use the mail command line, but i'm still not sure how to put text in the mail body).

I am also still not able to login with Uebimiau.

Are you sure you used the correct usernames? In Outlook, Outlook Express or any other email client you must use web3_boo, whereas in Uebimiau you use one of the email addresses you assigned to web3_boo (e.g. web3_boo@example.com).
Did you disable Maildir in Management -> Server -> Settings -> Email?

stlshawn 3rd April 2006 08:08

back again
 
I know this thread has sat dormant for a while, as has my server, but now i'm back and gonna try and get this to work. :)

Anyway, i got the outlook express part to work by enabling "requires secure connection" in outlook's settings.
:) Question One:
Is there any way to change this so it won't require a secure connection for email?

I still don't have eubimiau working properly. No matter who i login as, it just doesn't want to let me in.
:) Question Two:
Is there somewhere i can look and see if it is looking at the right spots on my server so it even knows who the users should be? Some sort of Eubimiau configuration file?

Also, I read on how to disable the user prefix under "management > system config> settings > isp manager". I would like to do this to tidy things up a bit for users, but i don't know if this will cause problems down the road.
:) Question 3:
Would this be generally bad?

EDIT:
I just realized i never posted this,
but when i try logging into the mail system with the Eubimiau, i get the following....

Apr 3 00:19:10 serv1 ipop3d[7520]: pop3 service init from 127.0.0.1
Apr 3 00:19:10 serv1 ipop3d[7520]: Command stream end of file while reading line user=??? host=localhost.localdomain [127.0.0.1]

Thanks in advance to any advice that can be given.

falko 3rd April 2006 13:05

Quote:

Originally Posted by stlshawn
I still don't have eubimiau working properly. No matter who i login as, it just doesn't want to let me in.

In Uebimiau you must log in with an email address instead of a username.

Quote:

Originally Posted by stlshawn
Is there somewhere i can look and see if it is looking at the right spots on my server so it even knows who the users should be? Some sort of Eubimiau configuration file?

There'S a configuration file: /home/admispconfig/ispconfig/web/webmail/inc/config.php.

Quote:

Originally Posted by stlshawn
Also, I read on how to disable the user prefix under "management > system config> settings > isp manager". I would like to do this to tidy things up a bit for users, but i don't know if this will cause problems down the road.
:) Question 3:
Would this be generally bad?

Have a look here: http://www.howtoforge.com/forums/showthread.php?t=2677


Quote:

Originally Posted by stlshawn
Apr 3 00:19:10 serv1 ipop3d[7520]: pop3 service init from 127.0.0.1
Apr 3 00:19:10 serv1 ipop3d[7520]: Command stream end of file while reading line user=??? host=localhost.localdomain [127.0.0.1]

Thanks in advance to any advice that can be given.

Create the file /etc/c-client.cf with the following content:
Code:

I accept the risk
set disable-plaintext 0

and restart inetd:
Code:

/etc/init.d/inetd restart


All times are GMT +2. The time now is 21:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.