HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   ISPconfig Dovecot problem (http://www.howtoforge.com/forums/showthread.php?t=21315)

dolmax 14th March 2008 07:50

ISPconfig Dovecot problem
 
Hi everyone,

I've installed ISPconfig on my Fedora Core 8 servers and really happy with the performance. One of my servers has been up and running for 2 months now, but I started facing a problem regarding Dovecot. Every morning when I get to my office, I see that the POP3 service is offline. If I try to restart the service by /etc/rc.d/init.d/dovecot restart I get a failure notice saying that the /etc/dovecot.conf is incorrect. In the same message I also receive another notification "dovecot is already running on PID XXXX". I basically reboot the system, and everything works like a charm.

Questions;
1. I could not find where the log files for dovecot are. Any pointers would be highly appreciated.
2. What do you think the problem could be?
3. Why did this happened over time? All I do is use yum to do full updates every now and then? Is this wrong?
4. How do I restart ISPConfig while the system is running?
5. How do I update ISPconfig services? Should I keep on using yum to update all installed appllications?

Thank you all,
DolmaX

till 15th March 2008 10:22

1) Dovecot should be logging to the file /var/log/maillog. But you might want to have a look into the dovecot.conf file if additional logging can be activated there.

2) Not easy to say. First try to find the file were dovecot logs to. It might even be a hardware problem.

3) Using yum frequently is fine and recommended.

4) /etc/init.d/ispconfig_server restart

But your problem is most likely not directly related to ispconfig, as ispconfig does not write configuration files for dovecot.

5) Use yum and additionally update to the latest ispconfig version.

dolmax 15th March 2008 14:17

Till thank you for that response.

I really don't know the methodology of ISPConfig yet, so I did not want to mess up the working system. I'll edit dovecot.conf to create a log path and see what I found. Strange but the server did not create the same problem today.

I'll check and report if I find something about this problem.

Regards,
DolmaX


All times are GMT +2. The time now is 10:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.