HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Problems with Xen 3.0 Debian Install (http://www.howtoforge.com/forums/showthread.php?t=21183)

sergiochacon 10th March 2008 15:52

Problems with Xen 3.0 Debian Install
 
Originally Posted by sergiochacon
Hey Falko,

I was trying the installation of xen 3 following your instructions on a Dell Poweredge 2300 that had Debian 4 and linux 2.6.8 installed. Everything went well until I got to make world. I got an error

...
`/usr/src/xen-3.0.3_0-src'
rm -rf tmp-linux-2.6.16.29 linux-2.6.16.29-xen
make[3]: Leaving directory `/usr/src/xen-3.0.3_0-src'
make[2]: Leaving directory `/usr/src/xen-3.0.3_0-src'
make[1]: Leaving directory `/usr/src/xen-3.0.3_0-src'
make dist
make[1]: Entering directory `/usr/src/xen-3.0.3_0-src'
make -C xen install
make[2]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
make -f Rules.mk _install
/bin/sh: line 1: gcc: command not found
/bin/sh: line 1: gcc: command not found
/bin/sh: line 1: gcc: command not found
make[3]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
make -C tools
make[4]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools'
make -C figlet
make[5]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
gcc -o figlet figlet.c
make[5]: gcc: Command not found
make[5]: *** [figlet] Error 127
make[5]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
make[4]: *** [default] Error 2
make[4]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools'
make[3]: *** [/usr/src/xen-3.0.3_0-src/xen/xen] Error 2
make[3]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
make[1]: *** [install-xen] Error 2
make[1]: Leaving directory `/usr/src/xen-3.0.3_0-src'
make: *** [world] Error 2
host1:/usr/src/xen-3.0.3_0-src# make install
make -C xen install
make[1]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
make -f Rules.mk _install
/bin/sh: line 1: gcc: command not found
/bin/sh: line 1: gcc: command not found
/bin/sh: line 1: gcc: command not found
make[2]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
make -C tools
make[3]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools'
make -C figlet
make[4]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
gcc -o figlet figlet.c
make[4]: gcc: Command not found
make[4]: *** [figlet] Error 127
make[4]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
make[3]: *** [default] Error 2
make[3]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools'
make[2]: *** [/usr/src/xen-3.0.3_0-src/xen/xen] Error 2
make[2]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
make: *** [install-xen] Error 2
host1:/usr/src/xen-3.0.3_0-src#

Can you provide me with assistance? Is this a common error and is there anything I can do about it?
Thanks for your help bro.
Sergio

sergiochacon 10th March 2008 21:03

Moving along
 
Well, I ran the tutorial again and found the error again, so I installed gcc again and it worked. So I was able to make world and then I did make install and got another error, so I installed patch and it is now doing its thing so I believe I might get lucky.

sergiochacon 12th March 2008 16:26

problem with xen install
 
After "make world" command, everything seemed to be going fine but after a couple of hours of compiling I got an error that said "no enough space" to continue. I originally used an 18GB scsi drive.

Changed to a 36GB scsi drive and retried but the same issue appeared. It seems though that it came at a different place in the compilation.

falko 13th March 2008 17:50

What's the size of the partition where you're compiling Xen? What's the output of
Code:

df -h
?

sergiochacon 13th March 2008 18:43

problem with xen install
 
Thanks for your reply, Falko.

I kept running out of space every time I tried to "make world" so I decided to reinstall debian with automatic partitioning. I also added the following to the Config.mk file:

CFLAGS = -fno-stack-protector -mno-tls-direct-seg-ref

before attempting make. It worked. I am moving along now buddy!

Thanks for the manual by the way. It would have been very difficult without it.

sergiochacon 14th March 2008 18:30

problem with xen install
 
Just when things were going well, i got a problem with setting up the template for the base system as of page 3. After successfully downloading from ftp2.de.debian.org/debian, found that when i apt-get install localesconfig, it does not exist, and when I tried to base-config, i get a terminated message.

Any idea?
I will try to create a base from another source in the meantime.

sergiochacon 14th March 2008 19:37

problem with xen install
 
trying xen-tools

falko 15th March 2008 18:19

Quote:

Originally Posted by sergiochacon
when i apt-get install localesconfig, it does not exist

It's
Code:

apt-get install localeconf


All times are GMT +2. The time now is 08:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.