HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   postfix help please (http://www.howtoforge.com/forums/showthread.php?t=2113)

onesandtwos 17th January 2006 16:20

postfix help please
 
Hi.

Bit new to PostFix and am having trouble setting it up.

I am trying to set up a null server that can send mail but not receive mail. The server running Postfix is on DMZ of network. We have an exchange Server on the LAN of the network that handles all receiving of mail. The postfix is for my webserver to send confirmation emails to internet users and that's it.

I followed the basic config and standard config for a null client in the documentation but its left me with some problems.

Program works fine sending mail to external mail addresses like hotmail, gmail, etc but when I try to send mail to mydomain.co.uk i get an error of "connect to mail.mydomain.co.uk[xxx.xxx.xxx.xxx]: Connection timed out" where xxx.xxx.xxx.xxx is the address of my router.

This is having a knock on effect of my mailq filling up with mail from root. Anybody have any ideas how to force emails to my domain to be sent externally? This should resolve the root@mydomain.co.uk problem shouldn't it? Really really need a hand... :confused:

Here are changes to config i've made....

in master.cf i've commented out local delivery agent (local) as per documentation instructions.

A printout of postconf -n is as follows...

command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
html_directory = /usr/share/doc/postfix-2.2.5/html
inet_interfaces = 127.0.0.1
local_transport = error:local delivery is disabled
mail_owner = postfix
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
mydestination = mydomain = co.uk
myhostname = mydomain
mynetworks = 127.0.0.0/8
mynetworks_style = host
myorigin = mydomain.co.uk
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.2.5/README_FILES relay_domains =
relayhost =
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop

falko 17th January 2006 17:35

I guess the problem is that mail.mydomain.co.uk points to your router which then forwards the request to your Postfix server which cannot respond because you set inet_interfaces to 127.0.0.1 .

The solution is to change the A record for mail.mydomain.co.uk so that it points to another server which can handle those mails.

themachine 19th January 2006 06:29

YTou may not actually want to change the DNS entry of the mail.mydomain.co.uk .

Answer these first...

Is this a NAT Firewall that is passing traffic to a NAT IP?

Where is mail for the "mydomain.co.uk" domain suppose to go? Is it suppose to go to the mail server which is behind the firewall?

If this box is on the DMZ and it is a NAT'd network... and you're trying to send mail to "mail.mydomain..." then it is trying to go out, and come back in which isn't going to work. If it is a NAT'd network, I would just try adding "w.x.y.z mail.mydomain.co.uk" to your '/etc/hosts' file where 'w.x.y.z' is your NAT'd IP Address. You will also need to verify your '/etc/nsswitch.conf' file to ensure that the line exists "hosts: files dns" this will ensure that files [/etc/hosts] are queried before DNS and therefore would send the message to the NAT'd IP host and not out and then in.

Does that make sense?


All times are GMT +2. The time now is 01:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.