HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   OpenLDAP + Samba Domain Controller On Ubuntu 7.10 (http://www.howtoforge.com/forums/showthread.php?t=21069)

bootzcat 6th March 2008 18:09

OpenLDAP + Samba Domain Controller On Ubuntu 7.10
 
Hi I'm at step 7 and get the following error can anyone shed some light on how to fix my issue... thank you


anduril:/etc/smbldap-tools# smbldap-populate -u 30000 -g 30000
Populating LDAP directory for domain anduril (S-1-5-21-1351355136-4248403401-1012834831)
(using builtin directory structure)

entry dc=anduril,dc=hufsd already exist.
adding new entry: ou=Users,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 3.
adding new entry: ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 4.
adding new entry: ou=Computers,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 5.
adding new entry: ou=Users,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 6.
adding new entry: uid=root,ou=Users,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 7.
adding new entry: uid=nobody,ou=Users,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 8.
adding new entry: cn=Domain Admins,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 9.
adding new entry: cn=Domain Users,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 10.
adding new entry: cn=Domain Guests,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 11.
adding new entry: cn=Domain Computers,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 12.
adding new entry: cn=Administrators,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 16.
adding new entry: cn=Account Operators,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 18.
adding new entry: cn=Print Operators,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 19.
adding new entry: cn=Backup Operators,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 20.
adding new entry: cn=Replicators,ou=Groups,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 21.
adding new entry: sambaDomainName=anduril,dc=anduril,dc=hufsd
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 21.

Please provide a password for the domain root:
/usr/sbin/smbldap-passwd: user root doesn't exist
anduril:/etc/smbldap-tools#

bootzcat 6th March 2008 20:41

SOLVED

I just had to give the user "admin" the correct password

execve4 17th March 2008 15:17

bootzcat, I have the same problem :/
How did you exactly correct this? Is 'admin' the system user?

Appeciate your help, I really need to get this done :/

bootzcat 18th March 2008 13:33

Make sure Step 2 and the following have the same password... and recheck the config files reguarding these instructions to make sure the password is the same throughout. If this doesn't help please post your output of smbldap-populate, it maybe something else...

# Give SAMBA the "admin" password to the LDAP tree.
smbpasswd -w 12345

execve4 18th March 2008 19:28

bootzcat, thanks for your respond. Finally I got this done ... but now, when reached end of the howto ... I can't join the domain with the WinXP (step 14)

I'm doing as it is in the howto, set the domain, hit 'OK', small window appears, enter 'root' and password and ... after a while I receive "Network path was not found" message :/

Did you have something like this? :/ I couldn't find anything useful in the logs, maybe I set something wrong in the configuration ... but everything seems to be ok. Just what is the "network path" according to Samba PDC ? :/

execve4 18th March 2008 20:16

ok, one next step done...
Network path is found, but the last problem (I think), when I trying to log as 'root' it returns that can't find username and in /var/log/samba/log.client-winxp the following entry is logged

Quote:

[2008/03/18 18:57:46, 0] passdb/pdb_interface.c:pdb_default_create_user(329)
_samr_create_user: Running the command `/usr/sbin/smbldap-useradd -w "client-winxp$"' gave 9
when I invoke the command manually I get this:
Quote:

host# /usr/sbin/smbldap-useradd -w "client-winxp$"
/usr/sbin/smbldap-useradd: user client-winxp$ exists
What's interesting that when I'm logging as anyone else or give 'root' incorect password it returns 'incorrect users/password', so it seems that 'root' is authorized correctly, but somehow is dropped at some kind of next stage ...

lucaspr 19th March 2008 21:00

Think it's a mistake somewhere....
 
Got the same error about the non-existing root user... So I checked and double checked my config files, schemas, etc, etc.

The output of my population command:
root@luukserver:/etc/smbldap-tools# smbldap-populate -u 30000 -g 30000
Populating LDAP directory for domain LP ( S-1-5-21-1930989509-4064009020-2983927688)
(using builtin directory structure)

entry dc=lp,dc=local already exist.
adding new entry: ou=Users,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 3.
adding new entry: ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 4.
adding new entry: ou=Computers,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 5.
adding new entry: ou=Idmap,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 6.
adding new entry: uid=root,ou=Users,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 7.
adding new entry: uid=nobody,ou=Users,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 8.
adding new entry: cn=Domain Admins,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 9.
adding new entry: cn=Domain Users,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 10.
adding new entry: cn=Domain Guests,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 11.
adding new entry: cn=Domain Computers,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 12.
adding new entry: cn=Administrators,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 16.
adding new entry: cn=Account Operators,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 18.
adding new entry: cn=Print Operators,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 19.
adding new entry: cn=Backup Operators,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 20.
adding new entry: cn=Replicators,ou=Groups,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 21.
adding new entry: sambaDomainName=LP,dc=lp,dc=local
failed to add entry: modifications require authentication at /usr/sbin/smbldap-populate line 495, <GEN1> line 21.

Please provide a password for the domain root:
/usr/sbin/smbldap-passwd: user root doesn't exist

Things I checked:
- Samba schema
- passwords for dpkg-reconfigure slapd and smbpasswd they match.
- config files

I am totally new when it comes to create a domain controller with linux.. the 'logon path = ' line doesn't it have to be 'logon path = \\luukserver\netlogon' or something. Don't know exactly, but thought about a possible error...

Could anyone help me out? Thanx in advance!

execve4 21st March 2008 15:31

lucaspr, make sure you have correct authorization data in /etc/smbldap-tools/smbldap_bind.conf


All times are GMT +2. The time now is 10:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.