HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   php5 on debian sarge (stable) (http://www.howtoforge.com/forums/showthread.php?t=2063)

ruskicar 14th January 2006 16:28

php5 on debian sarge (stable)
 
How to install php5 on Debian 3.1 stable?

till 14th January 2006 17:16

Quote:

Originally Posted by ruskicar
How to install php5 on Debian 3.1 stable?

You can use the php5 package from backports.org. Instrctions on how to configure your sources list where provided here:

http://www.backports.org/instructions.html

The PHP5 backports package is named "php5".

ruskicar 14th January 2006 17:31

Great! Thanks

geek.de.nz 15th February 2006 11:30

PHP5 on debian sarge
 
I tried like described at
http://www.debianhelp.co.uk/php5.htm

But for some reason I still can't run PHP5. It is installed as shown by apt-get. But when I run
#php -v
I get:
PHP 4.3.10-16 (cli) (built: Aug 24 2005 20:25:01)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

Also, when I run the phpinfo(); I get:
PHP Version 4.3.10-16
...

Someone knows how to actually activate php5? I even deleted php4 with
#apt-get remove php4
and restarted the webserver with
#/etc/init.d/apache2 restart
Even tried rebooting, but still it didn't work.

I need PHP5 because I'm using classes etc, otherwise I'll have to rewrite a lot of the stuff I'm developing to run on my vserver.

falko 15th February 2006 20:43

Quote:

Originally Posted by geek.de.nz
I tried like described at
http://www.debianhelp.co.uk/php5.htm

But for some reason I still can't run PHP5. It is installed as shown by apt-get. But when I run
#php -v
I get:
PHP 4.3.10-16 (cli) (built: Aug 24 2005 20:25:01)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

You used the command line PHP here. Did you install php5-cli?


Quote:

Originally Posted by geek.de.nz
Also, when I run the phpinfo(); I get:
PHP Version 4.3.10-16
...

Did you run that on the command line or in a web browser?

geek.de.nz 16th February 2006 03:06

Quote:

Originally Posted by falko
You used the command line PHP here. Did you install php5-cli?


Did you run that on the command line or in a web browser?

I did run that part in a web browser.

Anyway, I got it sorted now. I don't know why, but when I went through the steps again, it just worked. I think I might have missed out on the lib module or something. Well, anyway, it's working now, thnx though. :)


All times are GMT +2. The time now is 00:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.