HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Feature Requests (http://www.howtoforge.com/forums/forumdisplay.php?f=17)
-   -   Script questions && Gentoo version (http://www.howtoforge.com/forums/showthread.php?t=204)

hagel 6th August 2005 15:43

Script questions && Gentoo version
 
I'm trying to install ISPConfig on my dedicated Gentoo server, having to hack trough the setup scripts that I'm not that good at doing... Had to restart the damn setup a couple of times because of missing dependencies/applications, perhaps it is possible to let the setup script wait instead of terminating when something isn't right, it's not at all funny to have to let the script work from the beginning every time. I mean one could open a second terminal and correct what's wrong and then let the script try again, or isn't that possible?

Well, over to my sexond question, is there anything I should know when forcing ISPConfig to install on a Gentoo server? Just struck me that I should've asked that before starting to mess with it.

Regards
Tobbe

pfm.smits 11th October 2005 14:47

I am interested too
 
I am interested too in how to install on gentoo.

mistik1 30th November 2005 20:00

Gentoo support patches for ISPConfig-2.1.1
 
I have put togather a little patch for ispconfig to make it install in a gentoo environment.
There are a few things you need to know in order to use this patch.
1: The patch only support bind9 running in the default gentoo chroot environment. To setup this environment you need to install bind9 fresh and then run the ebuild config option as follows:
ebuild /var/db/pkg/net-dns/bind-9.2.2-r3/bind-9.2.5-r9.ebuild config
This will configure your bind install for chroot operation and setup the needed files in /chroot/dns/bind9.

2: The patch only currently supports apache-2.x (This can be changed with a little editor work :) )

3: I choose only to support proftpd standalone. (I would give my right arm for pure-ftpd support, maybe later)

4: Only postfix is supported by the patch.

5: Only vixie-cron is currently supported.
You can find the patch Here

I have issues with installing ANYTHING at all in my /root directory so for those who feel as I do I have made a second copy of the patch that installs ISPConfig in /opt rather than /root this patch contains my gentoo additions along with the /opt patch so it may be safely used on any of the supported OSes, You can find that patch Here

Felikz 13th February 2006 13:04

ISPConfig on Gentoo
 
Sounds fantastic, thought about producing an e-build for this ???

SupuS 7th May 2006 13:19

Hi

Did you sucessfully install ISPconfig on gentoo?

Thx


All times are GMT +2. The time now is 08:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.