HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Setting Signalfile Failed: update (http://www.howtoforge.com/forums/showthread.php?t=20380)

SupuS 13th February 2008 13:48

Setting Signalfile Failed: update
 
Hi guys

I installed ispconfig 2.2.20 (and install new file from 2.2.21) on new Ubuntu 7.10 server and everythink was ok. But now new configuration is not writen .. if I change anything in /home/admispconfig/ispconfig/ispconfig.log is only:

Code:

13.02.2008 - 12:18:10 =>  - Setting Signalfile Failed: update
If I run /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php manually so configuration is writen and I get this lines:

Code:

start
UPDATE: 2
UPDATE: 3
INSERT USER: 5
INSERT USER: 6

Warning: symlink(): File exists in /root/ispconfig/scripts/lib/config.lib.php on line 933
UPDATE USER: 3

Warning: symlink(): File exists in /root/ispconfig/scripts/lib/config.lib.php on line 933
UPDATE USER: 4
ende

Any idea how to solve it or where looking for the bug?

edit: This thing happend to me in version 2.2.20 but I reinstalled whole 2.2.20 and it disappears .. but now it is back again :(

edit 2: Now I found this in ispconfig log (after using manually writeconf):

Code:

13.02.2008 - 12:54:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
13.02.2008 - 12:54:02 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable

Thanks .. SupuS

SupuS 13th February 2008 15:22

Here is complete outoput of /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php in ispconfig log after adding some more test users:

Code:

13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 257: WARNING: could not setquota -g web3 1024000 1025024 0 0 -a &> /dev/null
13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 258: WARNING: could not setquota -T -g web3 604800 604800 -a &> /dev/null
13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 277: Connected successfully
13.02.2008 - 14:12:02 => INFO - USER:
web3test:x:10014:10013:Petr test:/var/www/web3/user/web3test:/bin/false
13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test 0 0 0 0 -a &> /dev/null
13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test 604800 604800 -a &> /dev/null
13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3test/.forward
13.02.2008 - 14:12:02 => INFO - USER:
web3test:x:10016:10013:test:/var/www/web3:/bin/false
13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test 0 0 0 0 -a &> /dev/null
13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test 604800 604800 -a &> /dev/null
13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/.forward
13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 117: symlink /var/www/web3/Maildir
13.02.2008 - 14:12:03 => INFO - USER:
web3:x:10018:10013:Prodej:/var/www/web3/user/web3:/bin/false
13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3 0 0 0 0 -a &> /dev/null
13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3 604800 604800 -a &> /dev/null
13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3/.forward
13.02.2008 - 14:12:03 => INFO - USER:
web3test3:x:10021:10013:Dotaz:/var/www/web3/user/web3test3:/bin/false
13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test3 0 0 0 0 -a &> /dev/null
13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test3 604800 604800 -a &> /dev/null
13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3test3/.forward
13.02.2008 - 14:12:03 => INFO - USER:
web3test2:x:10023:10013:test2:/var/www/web3/user/web3test2:/bin/false
13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test2 0 0 0 0 -a &> /dev/null
13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test2 604800 604800 -a &> /dev/null
13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3test2/.forward
13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1259: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
13.02.2008 - 14:12:04 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
13.02.2008 - 14:12:04 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
13.02.2008 - 14:12:04 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2018: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
13.02.2008 - 14:15:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
13.02.2008 - 14:15:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
13.02.2008 - 14:15:01 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
13.02.2008 - 14:15:01 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1259: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
13.02.2008 - 14:15:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2018: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~

Running of commands from WARN lines in command line is without errors

falko 14th February 2008 19:00

What's the output of
Code:

ls -l /bin/sh
?

SupuS 14th February 2008 20:02

Hi Falko

Thanks for replay. Here is command output:

Code:

#ls -l /bin/sh
lrwxrwxrwx 1 root root 9 Feb  8 22:17 /bin/sh -> /bin/bash

Yesterday I found that Ubuntu 7.10 probably has build in AppArmor feature. From /var/log/messages:

Code:

AppArmor: AppArmor initialized<5>audit(1202899231.350:2):  type=1505 info="AppArmor initialized" pid=1055
So I disabled it as described on https://help.ubuntu.com/community/AppArmor and reinstalled ispconfig again. Unfortunately AppArmor was up again after restart even if I disabled it as described on help page. I have to kill it before installation.
For now it seems ok but will see for some more testing. After last reinstallation it was ok too but next day error was back.

With disabling AppArmor gone away follow bind error message too:

Code:

Failure registering capabilities with primary security module.

falko 15th February 2008 19:06

Did you disable AppArmor using update-rc.d?

SupuS 15th February 2008 20:39

Yes I used

Code:

update-rc.d -f apparmor remove
but apparmor still alive next boot .. so I killed it by

Code:

/etc/init.d/apparmor kill

falko 16th February 2008 18:56

Do you see apparmor links in /etc/rc2.d, /etc/rc3.d, and /etc/rc5.d?

SupuS 19th February 2008 19:24

No. Will see after next reboot. I hope it will not start never more :)

SupuS 27th February 2008 18:40

So .. Setting Signalfile Failed: insert error is back again .. now I am almost sure that it is because of awstats plugin by djtremors on

http://www.djtremors.com/index.php?o...=25&Itemid=139

Have anybody similar problem with ispconfig 2.2.21 and this mode? After latest reinstall of 2.2.21 I forgot install awstat mode too .. and everything was ok .. today I found that stats not works .. so I installed awstat mode, generated statistics and error message is back again :(

Only one difference .. no WARN in /home/admispconfig/ispconfig/ispconfig.log .. only this line:

Code:

- Setting Signalfile Failed: insert
Any help welcome .. thanks SupuS

falko 28th February 2008 20:45

Did you check if AppArmor is still switched off?


All times are GMT +2. The time now is 20:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.