HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   When External IP is Change Error on DNS Service Occurs (http://www.howtoforge.com/forums/showthread.php?t=2012)

bluegrass 12th January 2006 07:31

When External IP is Change Error on DNS Service Occurs
 
I have an existing Web, DNS and Mail Server (Fedora Core) with an External IP address. I installed an Anti-Virus and Anti-Spam Hardware and connected the said Server to it's Internal/DMZ ports. I entered the Servers IP to the External IP of the new Hardware and changed the Servers IP to a private IP. When I did this, the DNS service of the said server won't work. I made some more adjustments on the DNS configuration files of the server; resolv.conf, named.conf, etc. but still DNS service won't work.

Are there still any other configuration files I should edit?

falko 12th January 2006 13:43

You mean your server has now a local IP address (behind some kind of router), and now it can't resolve any domains?

Is there anything related to this in the log in /var/log?
What's the output of
Code:

dig www.google.com
?
What's in /etc/resolv.conf and /etc/hosts?

Does
Code:

ping -c4 64.233.183.99
work?

bluegrass 13th January 2006 07:35

Thanks so much for the reply, falko...

There's nothing on the log related to the problem.

This morning, I tried, stopping the 'firewall' of the server and it seems that it works. the 'dig www.google.com' works out fine and it did gave an answer, also to www.yahoo.com, and even my url.

however, I am still waiting for any responses as to the outcome of the emails I sent to and from my Mail System which also resides on the same server as mentioned before. As of this writing there are no emails yet received on both recipients.

Again, thanks.

till 13th January 2006 12:56

Have you forwarded the smtp port from your router to your server and made sure its not blocked by a firewall?

Have you checked that your provider does not block port 25?

bluegrass 17th January 2006 03:08

Quote:

Originally Posted by till
Have you forwarded the smtp port from your router to your server and made sure its not blocked by a firewall?

Have you checked that your provider does not block port 25?

Thanks, till.

Yes, port 25 has been forwarded from the router and firewall to the server and vise-versa. My users can access their emails, unfortunately sending and receiving does not work properly. I also wonder why i can receive the automatic emails from my guestbook provider (third party), once a message is posted on our guestbook. I tried sending emails to yahoo and other corporate emails outside our domain, but sending fails....

As of the moment, I configured my servers back to its original network setup, and I will try to configure a new mail server, which will be installed behind the said Anti-Virus and Anti-Spam router/firewall and see if it works.

falko 17th January 2006 09:27

Please contact your ISP's support to find out if they block port 25.

bluegrass 17th January 2006 11:54

Quote:

Originally Posted by falko
Please contact your ISP's support to find out if they block port 25.

No, they don't block port 25. All ports are actually opened on the type of internet connection we subscribed. It is the disgression of the subscriber to filter out the unneeded ports by having a firewall (either hardware or software). In my existing network set-up prior to the acquisition of the Anti-virus and Anti-Spam/Firewall hardware I configured my Linux Server as Web/Mail/DNS and Firewall Server. Opening only certain ports for access (HTTP,SMTP,DNS,IMAP,POP).

When I installed the new hardware, I disabled the Firewall at the server.

falko 17th January 2006 19:01

What's in your mail log when users try to send/receive emails without success?


All times are GMT +2. The time now is 13:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.