HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   email problem, one client only (http://www.howtoforge.com/forums/showthread.php?t=20072)

chancer 2nd February 2008 19:53

email problem, one client only
 
I have a client who wants their email diverting to an existing email address. I already have a few clients set up doing that and it works perfectly. Neither I nor any clients apart from that one are having email problems just now, and I can't find what may be causing the problem.

I have tried adding one of my email addresses to the list of forwarding addresses, then sent an email to the client's address from one of my private email addresses - it bounces with Relay access denied in the bounce message.

So far as I can see, the email setup in ISPConfig is exactly the same as for all the other clients. Why would relay access be denied? Where do I look for a cure?

The logs are not telling me anything is untoward, just the usual lengthy list of E. Europeans probing for a spam relay.

Many thanks.

madmucho 2nd February 2008 20:16

Please can you describe situation at example?
As i see you want Forward mail addres to another address, is destination forward address hosted on same server?

PS : I try solve similiar problem today at one client, but not forwarding, only delivering and problem was in standart dns entery, was deleted :-)

chancer 2nd February 2008 20:41

Hi, madmucho, no the destination address is on another server, although my own address that I added to forward to is on the same server.

I have checked the DNS settings and they are correct. The web site is working and the MX records are set correctly according to dig.

madmucho 2nd February 2008 21:53

And any errors in ispconfig log, mail log ?

Take a look inside you domain folder
/var/www/problemdomain/.forward
is there mailaddresses to which users from domain want forward to?

chancer 4th February 2008 09:55

Yes. But

a) It's my address, which is th eone on the same server

b) The one the client wants mail forwarded to is missing

Also, I now understand a message I get from the server every 12 hours saying certain clients have overused their mail quotas - these all have email response addresses or forms on their sites.

This particular client has a radio campaign pointing people to their web site and they are losing a fortune. Would someone help me, urgently, please?

TIA,

Sorry, nearly forgot - spent hours poring over the logs, but couldn't find anything which told me what's happening. To be honest, I'm not even sure where to look or what I should be looking for.

till 4th February 2008 11:42

Please check the mail log file for errors. The mail log is in the directory /var/log/ and can be named maillog, mail.log or just mail

chancer 4th February 2008 12:37

I have mail.err mail.log mail.info and mail.warn - there are no entries in mail.err, mail.warn tells me clamav is out of date, as do the other two, reproduced below, mail.log then mail.info:

Code:

Feb  4 09:08:34 sww2 freshclam[25166]: Received signal: wake up
Feb  4 09:08:34 sww2 freshclam[25166]: ClamAV update process started at Mon Feb  4 09:08:34 2008
Feb  4 09:08:34 sww2 freshclam[25166]: SECURITY WARNING: NO SUPPORT FOR DIGITAL SIGNATURES
Feb  4 09:08:34 sww2 freshclam[25166]: See the FAQ at http://www.clamav.net/support/faq for an explanation.
Feb  4 09:08:34 sww2 freshclam[25166]: Your ClamAV installation is OUTDATED!
Feb  4 09:08:34 sww2 freshclam[25166]: Local version: 0.91.2 Recommended version: 0.92
Feb  4 09:08:34 sww2 freshclam[25166]: DON'T PANIC! Read http://www.clamav.net/support/faq
Feb  4 09:08:34 sww2 freshclam[25166]: main.inc is up to date (version: 45, sigs: 169676, f-level: 21, builder: sven)
Feb  4 09:08:34 sww2 freshclam[25166]: daily.inc is up to date (version: 5678, sigs: 33988, f-level: 21, builder: ccordes)
Feb  4 09:08:34 sww2 freshclam[25166]: --------------------------------------

Code:

Feb  4 09:08:34 sww2 freshclam[25166]: Received signal: wake up
Feb  4 09:08:34 sww2 freshclam[25166]: ClamAV update process started at Mon Feb  4 09:08:34 2008
Feb  4 09:08:34 sww2 freshclam[25166]: SECURITY WARNING: NO SUPPORT FOR DIGITAL SIGNATURES
Feb  4 09:08:34 sww2 freshclam[25166]: See the FAQ at http://www.clamav.net/support/faq for an explanation.
Feb  4 09:08:34 sww2 freshclam[25166]: Your ClamAV installation is OUTDATED!
Feb  4 09:08:34 sww2 freshclam[25166]: Local version: 0.91.2 Recommended version: 0.92
Feb  4 09:08:34 sww2 freshclam[25166]: DON'T PANIC! Read http://www.clamav.net/support/faq
Feb  4 09:08:34 sww2 freshclam[25166]: main.inc is up to date (version: 45, sigs: 169676, f-level: 21, builder: sven)
Feb  4 09:08:34 sww2 freshclam[25166]: daily.inc is up to date (version: 5678, sigs: 33988, f-level: 21, builder: ccordes)
Feb  4 09:08:34 sww2 freshclam[25166]: --------------------------------------

Not much help, I'm afraid.

chancer 4th February 2008 13:06

Update: The logs have been repeating those messages and making no other entries since Friday, when I downloaded the zipped log files and then deleted the zips which were there.

I don't understand why that has happened. I keep meaning to change the cron job so the zips will be emailed to me anyway.

chancer 4th February 2008 15:27

So, can anyone tell me how to get the logs recording normally again, so I can try some test emails and see what the logs say?

madmucho 4th February 2008 15:32

Normal logs about emails can be found usualy
/var/log/mail/info
There are whole mailserver comunication.
When i debug email mesages i using hardcore telnet :-)
telnet mailserver 25
and simulate connection like this
http://www.yuki-onna.co.uk/email/smtp.html

you can check log and see what is there.


All times are GMT +2. The time now is 16:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.