HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Question on Enabling Compiz Fusion On Ubuntu 7.10 (ATI Mobility Radeon 9200) HOWTO (http://www.howtoforge.com/forums/showthread.php?t=20016)

homeriq5 1st February 2008 01:40

Question on Enabling Compiz Fusion On Ubuntu 7.10 (ATI Mobility Radeon 9200) HOWTO
 
Hi,

I tried following your howto exactly to get desktop effects working, however for some reason Ubuntu is not letting me enable them still. I have the exact same graphics card that you used (ATI mobility radeon 9200) and am using the open source ATI driver to run it. I think it might be because i dont have xgl installed, but whenever i install it my graphics get messed up (In one instance, I couldn't get past the login window after I restarted). Do you have any suggestions?

Thanks so much!

falko 1st February 2008 16:37

Are there any errors related to this in your logs?

homeriq5 1st February 2008 19:13

Well, specifically related to the howto I didnt get any error messages except when I tried to enable dekstop effects in the last step (It just siad that it couldnt enable it still). I guess my question should be how did you get compiz/compiz-fusion/xgl to work properly with your graphics card?

Here are some related errors that I get regarding trying to get compiz to work:

Code:

homeriq5@homeriq5-laptop:~$ compiz
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:5c61 (rev 01) (prog-if 00 [VGA])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
aborting and using fallback: /usr/bin/metacity

my graphics card
Code:

homeriq5@homeriq5-laptop:~$ lspci
01:00.0 VGA compatible controller: ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200 (AGP)] (rev 01)

my xorg.conf
Code:

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#  sudo dpkg-reconfigure -phigh xserver-xorg
Section "Files"
EndSection

Section "Module"
        Load                "glx"
        Load                "GLcore"
        Load                "v4l"
EndSection

Section "InputDevice"
        Identifier        "Generic Keyboard"
        Driver                "kbd"
        Option                "CoreKeyboard"
        Option                "XkbRules"        "xorg"
        Option                "XkbModel"        "pc105"
        Option                "XkbLayout"        "us"
EndSection

Section "InputDevice"
        Identifier        "Configured Mouse"
        Driver                "mouse"
        Option                "CorePointer"
        Option                "Device"        "/dev/input/mice"
        Option                "Protocol"        "ImPS/2"
        Option                "ZAxisMapping"        "4 5"
        Option                "Emulate3Buttons"        "true"
EndSection


Section "InputDevice"
        Identifier        "Synaptics Touchpad"
        Driver                "synaptics"
        Option                "SendCoreEvents"        "true"
        Option                "Device"        "/dev/psaux"
        Option                "Protocol"        "auto-dev"
        Option                "HorizScrollDelta"        "0"
EndSection

Section "Device"
        Identifier        "Failsafe Device"
        Boardname        "vesa"
        Busid                "PCI:1:0:0"
        Driver                "ati"
        Screen        0
        Option                "MergedFB"        "off"
EndSection

Section "Monitor"
        Identifier        "Failsafe Monitor"
        Vendorname        "Generic LCD Display"
        Modelname        "LCD Panel 1440x900"
        Horizsync        31.5-56.0
        Vertrefresh        56.0 - 65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
        Gamma        1.0
EndSection

Section "Screen"
        Identifier        "Default Screen"
        Device                "Failsafe Device"
        Monitor                "Failsafe Monitor"
        Defaultdepth        24
        SubSection "Display"
                Depth        24
                Virtual        1024        768
                Modes                "1024x768@60"        "800x600@60"        "800x600@56"        "640x480@60"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier        "Default Layout"
  screen 0 "Default Screen" 0 0
        Inputdevice        "Generic Keyboard"
        Inputdevice        "Configured Mouse"
        Inputdevice        "Synaptics Touchpad"
EndSection
Section "device" #
        Identifier        "device1"
        Boardname        "vesa"
        Busid                "PCI:1:0:0"
        Driver                "ati"
        Screen        1
        Option                "MergedFB"        "off"
EndSection
Section "screen" #
        Identifier        "screen1"
        Device                "device1"
        Defaultdepth        24
        Monitor                "monitor1"
EndSection
Section "monitor" #
        Identifier        "monitor1"
        Gamma        1.0
EndSection
Section "ServerFlags"
EndSection

fglrxinfo
Code:

homeriq5@homeriq5-laptop:~$ fglrxinfo
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

Also, installing xserver-xgl isnt a problem, its when I restart and log back in the graphics dont work and I have to reset the screen resolution settings and graphics card. Is there any other code I should run to help me get to the source of the problem?

Thanks so much

homeriq5 1st February 2008 23:00

Solved
 
I was able to solve this problem by following the directions from this site:

http://ubuntuforums.org/showthread.p...2&goto=newpost


All times are GMT +2. The time now is 10:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.