HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Mail doesn't work to people in same domain (http://www.howtoforge.com/forums/showthread.php?t=19967)

bswinnerton 30th January 2008 22:55

Mail doesn't work to people in same domain
 
For some reason I cannot mail people in my domain. Anyone outside of the domain works fine. I looked in the main.log

Code:

Jan 30 16:48:28 myserver postfix/pickup[7106]: D71701C851E: uid=33 from=<user@mysite.com>
Jan 30 16:48:28 myserver postfix/cleanup[7146]: D71701C851E: message-id=<220d34c505dfb7cfb011f7187d574b74@localhost>
Jan 30 16:48:28 myserver postfix/qmgr[7107]: D71701C851E: from=<user@mysite.com>, size=499, nrcpt=1 (queue active)

thats the only thing that looked odd. The other things on there besides that are logons and logouts

bswinnerton 31st January 2008 00:09

The mail that I try to send to someone in the same domain doesn't even show up in the mail.log

Ever heard of this?

bswinnerton 31st January 2008 02:11

I just noticed, I can't even email to myself.

-Nevermind, it just takes a little while to email myself. I still cannot email anyone on my server. However i can from something like gmail.

Hans 31st January 2008 17:10

That link results into an error 403. So i guess that's not correct.

bswinnerton 31st January 2008 17:11

Fixed the link..

Link removed for privacy reasons

Hans 31st January 2008 17:17

Did you enable the Maildir format within ISPConfig under Management > Server > Settings > Email ? What's within your Postfix configuration file /etc/postfix/main.cf ?

bswinnerton 31st January 2008 17:22

Yes the maildir is checked there.

Here is my main.cf
Code:

Edited for privacy reasons

bswinnerton 31st January 2008 17:32

Here is another interesting log. This is mail.info under var/log/

What i did in this session is login as webmaster, send mail to a user and then logged out. This is the log of that:

Code:

Edited for privacy reasons

bswinnerton 31st January 2008 17:46

Okay, I realized one thing that I was doing wrong. I was changing the paths for the /etc/passwd for FTP which was causing me not to be able to login or send the mail, which make sense.

Okay so I reset all of those passwords that I had changed which has ISPConfig update the home directories for those users.

But i'm still having the problem that I can't send local mail! =(

bswinnerton 31st January 2008 17:50

Sorry to rack up this thread. But I fixed it.

All of the emails for my users were taken from an old ispconfig server and just dumped into the maildir directories which must have some file that wasn't allowing the emails to be sent. After creating a new user and trying to send a message to that user it worked. My next step is to re-create the users and then try to salvage their emails.

Thanks everyone for your help.


All times are GMT +2. The time now is 21:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.