HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Networking problem - Fedora 8 (http://www.howtoforge.com/forums/showthread.php?t=19753)

nbc 24th January 2008 01:54

Networking problem - Fedora 8
 
I burned a Fedora 8 live CD this afternoon. Works fine. Decided to install it on my hard drive. That also worked. I have a single ethernet card, which I configured with a fixed IP address (192.168.x.y). Set the gateway to be my internet firewall machine.

However, when I reboot the machine, it configures the IP address, and then a few seconds later, decides that it needs to run dhcp (which I explicitly disabled, along with disabling IPv6). When the dhcp request times out, the system resets my IP address to 169.24.x.y - and then it can't locate my network at all....

Several questions - I really need to fix this - I need this machine back on the net...

1) How do I stop this from happening? It needs to believe that I want the static IP address

2) What is avahi-daemon? Do I need to have it running? One of the config files says it should not be used if network discovery isn't being done - and it isn't in this system... How do I turn it off??

3) Unrelated to networking - Fedora 8 installs only Gnome and I prefer KDE.
Once the network is running, will 'yum install kde' install all the kde software?
If I want to try kde4, what is the correct way to install that instead of kde3?

thanks very much for your help,

nbc

glennzo 24th January 2008 02:24

Quote:

Originally Posted by nbc
I burned a Fedora 8 live CD this afternoon. Works fine. Decided to install it on my hard drive. That also worked. I have a single ethernet card, which I configured with a fixed IP address (192.168.x.y). Set the gateway to be my internet firewall machine.

However, when I reboot the machine, it configures the IP address, and then a few seconds later, decides that it needs to run dhcp (which I explicitly disabled, along with disabling IPv6). When the dhcp request times out, the system resets my IP address to 169.24.x.y - and then it can't locate my network at all....

Several questions - I really need to fix this - I need this machine back on the net...

1) How do I stop this from happening? It needs to believe that I want the static IP address

Did you use System > Administration > Network to set the static ip?
Quote:

Originally Posted by nbc
2) What is avahi-daemon? Do I need to have it running? One of the config files says it should not be used if network discovery isn't being done - and it isn't in this system... How do I turn it off??

System > Administration > Services. Uncheck it for level 5.
Quote:

Originally Posted by nbc
3) Unrelated to networking - Fedora 8 installs only Gnome and I prefer KDE.
Once the network is running, will 'yum install kde' install all the kde software?

Applications > Add / Remove Software. Right side of the screen. KDE is probably already checked as installed. Can you log out and log back in, but click 'session' and choose KDE?
Quote:

Originally Posted by nbc
If I want to try kde4, what is the correct way to install that instead of kde3?

I'm not sure but I think if you want KDE4 installed then you would have to step into 'rawhide' (development) territory. Dangerous if you want a reliable desktop. Fun if you like to play with Linux. You can get a live CD from RedHat. https://www.redhat.com/archives/fedo.../msg00145.html

thanks very much for your help,

nbc[/QUOTE]

nbc 24th January 2008 02:41

Networking Problem - Fedora 8
 
1) Originally I set the static IP during the Live CD install scripts. After rebooting and having the problem, I used the network admin program to play with it - the IP address is set up correctly - the problem is it insists on overriding it with a dhcp request and I even though dhcp is not enabled or configured on that device, it still does it - I need to know how to stop the dhcp override.

2) I can disable it - but should I?

3) I think KDE is not installed during the live cd install. It is not available as a 'new session' option. The Add/Remove software program doesn't run because it can't connect to the network to examine the repositories...

Any suggestions?

thanks,

nbc

topdog 24th January 2008 08:27

I think it is either networkmanager or avahi that is changing your configuration to dhcp just disable the two and your static configuration should work.

nbc 24th January 2008 14:15

Networking problem - Fedora8
 
I disabled the avahi daemon. How do I disable the network manager? And is that something I really want to do???

thanks,

nbc

topdog 24th January 2008 15:01

To disable netmanager on an interface set
Code:

NM_CONTROLLED=no
in the interface's configuration file /etc/sysconfig/network-scripts/ifcfg-<interface>

nbc 24th January 2008 16:06

Netowrking problem - Fedora 8
 
Thanks - I will give that a try when I get home tonight...

nbc

nbc 27th January 2008 05:35

Networking problem - Fedora 8 - solved??
 
I seem to have solved the problem - but I'm not sure I believe the solution. Figured I would post it just for the record.

The day after I loaded Fedora 8 (and it was giving me all this grief) the system started screaming like a 747 on takeoff - one of the fans in the case appears to be breaking... I shut the machine down. This afternoon I pulled out the fan and popped in a new one.

Rebooted the machine - the network card came up 'inactive'. I used the network gui tool and hit the 'activate' button. Loaded my static IP address and has been running fine since....

I successfully did a 'yum update' and rebooted with the updated kernel. Same thing - the network card does not come up on boot - I think it should according to the config files. But as soon as I start it, the system appears to be working properly.

Who knew fans had so much control over the system :) :) :)

nbc


All times are GMT +2. The time now is 17:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.