HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   UebiMiau inbox / receiving mail problems (http://www.howtoforge.com/forums/showthread.php?t=19670)

jokn00 22nd January 2008 04:55

UebiMiau inbox / receiving mail problems
 
I installed the UebiMiau.pkg for ispconfig and everything seemed to be working okay. My mailserver is postfix and it shows smtp and pop3 running. I setup the mail accounts for the site through ispconfig and set a forward address as well. When I send an email to the address example@mydomain.com it forwards to the correct address but it does not show up in the inbox when I login to the mail client. I tried accessing my inbox with a regular email client and it accessed the inbox fine but it did not show that I had received any mail. When I tried to send mail through the client it would not connect through smtp. I checked the user's mail directory as well and there is no mail received. What am I missing here that's causing me to not be able to send or receive mail other than through a forwarded mail address for the created email accounts?

till 22nd January 2008 08:14

Do you get any errors in the mail log file?

jokn00 22nd January 2008 08:54

I don't see any errors in /var/log/mail.log

I sent mail from my ISPs email to my newly created domain email and then logged into the webmail client and refreshed the inbox a few times. This is what the logs say.

Email addresses have been edited.

my_email@home_domain.net This is my home email address.

web2_ispconfigmail@localhost.com This is the mail login created by ispconfig

admin@local_domain.com This is the mail address the original mail was sent to. It was setup through the options in ISPconfig also.

Here's the log, I can repaste it here if you don't allow linking to pastebin.

http://pastebin.com/m1562f97b

till 23rd January 2008 09:23

Did you try enable maildir under management > server > settings in ISPConfig? Maildir is needed if you use courier or dovecot as pop3 and imap server.

jokn00 23rd January 2008 13:25

Thanks for the help so far and yes, maildir is enabled. Any other suggestions?

falko 24th January 2008 14:43

What's the output of
Code:

netstat -tap
? Which distribution are you using?

jokn00 25th January 2008 01:39

I'm using ispconfig 2.2.19 and UebiMiau Webmail 2.7.2.

output of netstat -tap

Code:

Proto Recv-Q Send-Q Local Address          Foreign Address        State                                                                                                        PID/Program name
tcp        0      0 *:mysql                *:*                    LISTEN    8                                                                                                455/mysqld
tcp        0      0 *:www                  *:*                    LISTEN    1                                                                                                5324/apache2
tcp        0      0 *:81                    *:*                    LISTEN    1                                                                                                8812/ispconfig_htt
tcp        0      0 *:ftp                  *:*                    LISTEN    2                                                                                                9746/proftpd: (acc
tcp        0      0 li19-88.members.:domain *:*                    LISTEN    2                                                                                                5645/named
tcp        0      0 localhost.locald:domain *:*                    LISTEN    2                                                                                                5645/named
tcp        0      0 *:smtp                  *:*                    LISTEN    1                                                                                                3844/smtpd
tcp        0      0 localhost.localdoma:953 *:*                    LISTEN    2                                                                                                5645/named
tcp        0      0 *:https                *:*                    LISTEN    1                                                                                                5324/apache2
tcp6      0      0 *:imaps                *:*                    LISTEN    5                                                                                                682/couriertcpd
tcp6      0      0 *:pop3s                *:*                    LISTEN    5                                                                                                589/couriertcpd
tcp6      0      0 *:pop3                  *:*                    LISTEN    5                                                                                                522/couriertcpd
tcp6      0      0 *:imap2                *:*                    LISTEN    5                                                                                                625/couriertcpd
tcp6      0      0 *:ssh                  *:*                    LISTEN    2                                                                                                434/sshd
tcp6      0      0 *:smtp                  *:*                    LISTEN    1                                                                                                3844/smtpd
tcp6      0      0 ip6-localhost:953      *:*                    LISTEN    2

Thanks for the help.

till 25th January 2008 09:20

Please post the lines that appear in the mail log file when you send a email to a account on your server.

jokn00 25th January 2008 10:03

I created a new email to test so i could paste the log output, but the new address is working with no problems. Maybe because I enabled maildir after the accounts were created? I tried deleting one account and re-creating and it gives me an error saying "duplicate email address". Is there a way to re-create the email address again? Everything seems to be working now.

falko 26th January 2008 18:42

Quote:

Originally Posted by jokn00
I tried deleting one account and re-creating and it gives me an error saying "duplicate email address".

You must delete the old email address from the recycle bin first.


All times are GMT +2. The time now is 21:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.