HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Remote FTP (http://www.howtoforge.com/forums/showthread.php?t=196)

nsworld 5th August 2005 02:35

Remote FTP
 
I too have a problem with remote ftp access from users.
using Fedora 4, I create the domain activate ftp and then add users.
I can use the browser ftp ( https://192.168.55.4:81/index.php?s=ae....etc ) but not cuteftp with the same credentials.

any ideas , ftp server is running according to the services menu

till 5th August 2005 07:30

Quote:

Originally Posted by nsworld
I too have a problem with remote ftp access from users.
using Fedora 4, I create the domain activate ftp and then add users.
I can use the browser ftp ( https://192.168.55.4:81/index.php?s=ae....etc ) but not cuteftp with the same credentials.

any ideas , ftp server is running according to the services menu

The WebFTP Interface uses the normal FTP commands, so i assume thet FTP
is working generally. Maybe the problem is your firewall configuration?

nsworld 5th August 2005 13:03

I dont think its firewall as I'm on the local network behind the router,
I also have maped to the server through my own host file to by pass any dns.
Also Cuteftp does connect to the ftp server as I get the connection message, the problem is that it wont accept any user logging in

ftp access is enabled for the user (i presume this is working as i can use the ispconfig interface through the browser)

The reason I would like ftp to work through a client is that I have not found a way to transfer multiply files with the web browser method,
I did find a work around by installing MC and using the shell connect (f9) to access the old server to transfer the web pages across but I dont want to give users shell access.

just another thing maybe a wee bit off topic but where is phpmyadmin located/installed by default, I cant find it and installed the standard one in /home/admispconfig/ispconfig/web/phpMYAdmin
but again there is the problem of getting it intregrated into the admin facilities of ispconfig or setting up individual users manuall to be able to manage their dbases. - sorry if its a bit longwinded its the first time I do server like this normally used distros like clarkconnect.

(edit) firewall off on machine

I get this in logs :-
proftpd:
Unknown Entries:
session opened for user web1_nsworld by (uid=0): 16 Time(s)
session opened for user web1_kelljes by (uid=0): 5 Time(s)
authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=127.0.0.1
user=web1_nsworld: 2 Time(s) if it sheds any light !

admin 5th August 2005 13:22

Quote:

Originally Posted by nsworld
I dont think its firewall as I'm on the local network behind the router,
I also have maped to the server through my own host file to by pass any dns.
Also Cuteftp does connect to the ftp server as I get the connection message, the problem is that it wont accept any user logging in

ftp access is enabled for the user (i presume this is working as i can use the ispconfig interface through the browser)

Can you enable "Passive Transfers" in your FTP client and try again?

Quote:

Originally Posted by nsworld
just another thing maybe a wee bit off topic but where is phpmyadmin located/installed by default, I cant find it and installed the standard one in /home/admispconfig/ispconfig/web/phpMYAdmin
but again there is the problem of getting it intregrated into the admin facilities of ispconfig or setting up individual users manuall to be able to manage their dbases. - sorry if its a bit longwinded its the first time I do server like this normally used distros like clarkconnect.

You have to go to Management -> Update Manager -> Update and install the phpmyadmin pkg package from www.ispconfig.org. Afterwards, you have a link to phpmyadmin under Tools. The directory where it's installed is /home/admispconfig/ispconfig/web/phpmyadmin.

nsworld 5th August 2005 14:54

Ok phpmyadmin sorted but no luck on ftp access even with passive mode selected

falko 5th August 2005 15:17

Quote:

Originally Posted by nsworld
Ok phpmyadmin sorted but no luck on ftp access even with passive mode selected

Maybe your FTP server listens only on 127.0.0.1? Can you post the output of
Code:

netstat -tap
here?

nsworld 5th August 2005 15:45

[root@www home]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 1801/xinetd
tcp 0 0 *:32769 *:* LISTEN 1427/rpc.statd
tcp 0 0 *:pop3s *:* LISTEN 1801/xinetd
tcp 0 0 *:mysql *:* LISTEN 1891/mysqld
tcp 0 0 *:pop3 *:* LISTEN 1801/xinetd
tcp 0 0 *:imap *:* LISTEN 1801/xinetd
tcp 0 0 *:sunrpc *:* LISTEN 1410/portmap
tcp 0 0 *:81 *:* LISTEN 2180/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 2327/proftpd: (acce
tcp 0 0 home.!!!!!!!!!!!!!!!!!.com:ipp *:* LISTEN 1722/cupsd
tcp 0 0 home.!!!!!!!!!!!!!!!!!.com:5335 *:* LISTEN 1709/mDNSResponder
tcp 0 0 *:smtp *:* LISTEN 8589/master
tcp 1 10 home.!!!!!!!!!!!!!!!!!.com:smtp web25603.mail.ukl.yah:35834 LAST_ACK -
tcp 1 10 home.!!!!!!!!!!!!!!!!!.com:smtp web25603.mail.ukl.yah:35835 CLOSING -
tcp 0 0 192.168.55.6:52442 www.!!!!!!!!!!!!!!!!!.com:ssh ESTABLISHED 2933/ssh
tcp 0 0 *:http *:* LISTEN 2220/httpd
tcp 0 0 *:ssh *:* LISTEN 1793/sshd
tcp 0 0 *:https *:* LISTEN 2220/httpd
tcp 0 0 home.!!!!!!!!!!!!!!!!!.com:ssh ::ffff:192.168.55.3:2283 ESTABLISHED 4400/2
tcp 0 0 home.!!!!!!!!!!!!!!!!!.com:ssh ::ffff:192.168.55.3:1148 ESTABLISHED 2797/sshd: web1_nsw
[root@www home]#

falko 5th August 2005 16:11

Your POP3 daemon is a funny guy:

:pop3

:D

Well, if you like, you can send me a private message or email, and I can have a short look at your server...

nsworld 5th August 2005 16:40

yep -- interfeering smilies :p

what need I do to let you look at server ?

falko 5th August 2005 17:37

Quote:

Originally Posted by nsworld
yep -- interfeering smilies :p

what need I do to let you look at server ?

I've just sent you a private message.


All times are GMT +2. The time now is 20:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.