HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Wrong MySQL password?? (http://www.howtoforge.com/forums/showthread.php?t=1959)

Blu3 8th January 2006 09:36

Wrong MySQL password??
 
For some reason all 4 times Ive ran the ./setup program for ISPConfig, it states all prerequisites met and when I get to the part where I enter in my MySQL info, the setup program quits and states incorrect password detected???

Ive even tested the password by logging into mysql with that user account and password, and it works fine.

I followed these instructions: http://www.howtoforge.com/perfect_setup_ubuntu_5.10 to the exact letter and am pretty much stumped. Why does it not recognize the mysql login?

TIA

till 8th January 2006 12:23

Does your mysql password contains any special characters like this: !"$%&/#* ?

rdmandel 8th December 2006 21:45

mysql password problem
 
Till asks if the MySQL password contains special characters - are the characters listed by Till not allowed? And I did use some of them and now what do I do about it?

I have tried all the fixes I can find and am still unable to get the system to accept:
#> mysqladmin -u root password blahblah
mysqladmin: connect to server at 'localhost' failed
"error: access denied for user 'root'@'localhost' failed"

SOMEHOW, USING EVERYTHING I COULD FIND ON THE WEB, I WAS ABLE TO RESET THE PASSWORD TO '' AND THEN RESET IT TO A REAL PASSWORD, SO NOW THAT IS FIXED,

BUT IT STILL WILL NOT RECOGNIZE MY HOSTNAME
.

root#> mysqladmin -h GX270.tech-transfer.com -u root password Mand1eMM
ERROR - GX270.tech-transfer.com is not allowed to connect to this MySQL server

and
root#> telnet gx270.tech-transfer.com 3306
connects then Phost says 'GX270.tech-transfer.com' is not allowed to connect to this MySQL server. Closed by foreign host

and
root:#>hostname
GX270.tech-transfer.com
and
root:#>hostname -f
GX270.tech-transfer.com

falko 9th December 2006 14:55

What's the output of
Code:

netstat -tap
?

rdmandel 9th December 2006 17:04

netstat -tap
 
netstat - tap shows what it is supposed to show as per the how-to with some strangeness:
1) I have uninstalled mysql, but it still shows up;
2) it shows my host as GX270.tech-trans:domain when the hostname and hostname -f commands show the proper name (GX270.tech-transfer.com) but maybe this is an abrreviation for the netstat format.

tcp 0 0 *:mysql *:* LISTEN 3829/mysqld
tcp 0 0 *:ftp *:* LISTEN 4138/proftpd: (acce
tcp 0 0 GX270.tech-trans:domain *:* LISTEN 3671/named
tcp 0 0 localhost:domain *:* LISTEN 3671/named
tcp 0 0 *:smtp *:* LISTEN 4039/master
tcp 0 0 localhost:953 *:* LISTEN 3671/named
tcp6 0 0 *:imaps *:* LISTEN 3746/couriertcpd
tcp6 0 0 *:pop3s *:* LISTEN 3783/couriertcpd
tcp6 0 0 *:pop3 *:* LISTEN 3763/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 3728/couriertcpd
tcp6 0 0 *:www *:* LISTEN 4181/apache2
tcp6 0 0 *:ssh *:* LISTEN 4068/sshd
tcp6 0 0 *:smtp *:* LISTEN 4039/master
tcp6 0 0 ip6-localhost:953 *:* LISTEN 3671/named
tcp6 0 0 *:https *:* LISTEN 4181/apache2

And this from ps aux | grep mysql

root 3812 0.0 0.5 2616 1284 ? S 08:29 0:00 /bin/sh /usr/bin/mysqld_safe
mysql 3829 0.0 5.8 101732 14948 ? Sl 08:29 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/GX270.tech-transfer.com.pid --skip-locking
root 3830 0.0 0.1 1548 500 ? S 08:29 0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
root 4315 0.0 0.3 2876 792 tty1 R+ 09:10 0:00 grep mysql

sgrayban 10th December 2006 12:26

I had the same issue and installed webmin and added the local hostname to the host table and all was good.

Might want to make sure that localhost is allowed along with setting root's password while you are there.

falko 10th December 2006 14:19

Quote:

Originally Posted by rdmandel
netstat - tap shows what it is supposed to show as per the how-to with some strangeness:
1) I have uninstalled mysql, but it still shows up;

You have uninstalled MySQL? :confused:

Quote:

Originally Posted by rdmandel
but maybe this is an abrreviation for the netstat format.

Yes, it's an abbreviation.

rdmandel 10th December 2006 18:41

Actually ended up doing a clean install of the entire thing...........


All times are GMT +2. The time now is 12:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.