HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Yum update fails when setting up server (http://www.howtoforge.com/forums/showthread.php?t=19544)

RonH 17th January 2008 08:03

Yum update fails when setting up server
 
Hello All!

I'm trying to set up my first web server, using this tutorial, but I got to step 5 on page 3 where I'm supposed to do a:
Code:

yum update
I tried it, but I get back a
Code:

Setting up Update Process
Setting up repositories
Cannot find a valid baseurl for repo: update
Error: Cannot find a valid baseurl for repo: update

I looked around on google and it seems people usually suggest doing a:
Code:

ping www.google.com
I tried that, I get:
Code:

ping: unknown host www.google.com
Some people were saying that they could ping IP addresses, so I tried pinging my laptop (connected wirelessly if that matters) IP and I got:
Code:

connect: Network is unreachable
And if it helps, here is my /etc/resolv.conf
Code:

search rondotexe.com
nameserver 24.93.41.125
nameserver 24.93.41.126

I bought the domain (rondotexe.com) so I figured that's what I was supposed to put there, and I got the two DNS IPs from /ipconfig /all using the command line cmd.exe in windows.

I figure this has something to do with my internet connection. My internet works just fine (I'm on that connection right now. But is there some other problem?

Oh yes, last thing. On this page, I made my /etc/hosts look like this:
Code:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1              localhost.localdomain localhost
10.3.134.72            mesb.rondotexe.com mesb

*mesb is the name of the server. I got the IP address (10.3.134.72) from my ISP.

Sorry for all this information, but I figured if I didn't tell you guys from the get-go, you'd ask.

devnull3d 17th January 2008 09:52

It looks like your name servers are down
Code:

home:~# cp /etc/resolv.conf /etc/resolv.conf_bak
home:~# echo nameserver 24.93.41.125 > /etc/resolv.conf
home:~# echo nameserver 24.93.41.126 >> /etc/resolv.conf
home:~# ping google.com
ping: unknown host google.com

Try using open DNS servers such as 4.2.2.2 and 4.2.2.1 or contact your ISP to supply you with their nameservers.
And BTW 10.0.0.0/8 is a private netblock. So it only works on your local network, but not on the internet.
Try pinging 4.2.2.2 if you get a reply you're OK to go, if not then your box isn't on the internet :)

RonH 17th January 2008 15:21

Thanks devnull3d!

I figured that IP (and another one that was 66.xx.xx.xx.xx) were different than the ones I usually see on computer. I guess I was trying to set up a internet server without ordering business cable, and this is how they'd make it so that I can't do that.

I'm going to try changing the DNS Servers and I'll post the effects later today.


All times are GMT +2. The time now is 01:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.