HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   ISPConfig 2.2.19: Problems with ClamAV compilation on older Linux distributions (http://www.howtoforge.com/forums/showthread.php?t=19222)

till 9th January 2008 18:02

ISPConfig 2.2.19: Problems with ClamAV compilation on older Linux distributions
 
If your ISPConfig 2.2.19 update stops, dont panic. Please check if you see the following error message in the compilation output:

Quote:

checking for gcc bug PR28045... configure: error: your compiler has gcc PR28045 bug, use a different compiler, see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28045
ERROR: Could not configure ClamAV
This error may occur if you use a older linux distribution like Ubuntu 6.x, SuSE 10 or Fedora 4 (just a few where I heard about this problem). This problem is caused by the ClamAV script, the ClamAV developers have added a check that prevents the compilation of the latest ClamAV version with some gcc compiler versions which are buggy.

The recommended solution from the ClamAV dev's: Update GCC

The problem is, newer gcc packages are not available anymore for these linux distributions. Older gcc versions may work too, so downgrading gcc can be an option.

I collected here some workarounds:

Ubuntu 6.06 LTS: http://www.howtoforge.com/forums/sho...4&postcount=27

For all other linux distributions, the following steps should help:

1) Execute:

mkdir /root/ispconfig

to make sure that the ispconfig installer performs a update, when we start it again.

2) Unpack the file ISPConfig-2.2.19.tar.gz again. Then edit the file:

install_ispconfig/compile_aps/compile

and replace the line (160):

Code:

./configure --prefix=/home/adm${APPLICATION_NAME}/${APPLICATION_NAME}/tools/clamav --sysconfdir=/home/adm${APPLICATION_NAME}/${APPLICATION_NAME}/tools/clamav/etc --with-user=adm${APPLICATION_NAME} --with-group=adm${APPLICATION_NAME} --disable-clamav --disable-bzip2 --disable-zlib-vcheck || error "Could not configure ClamAV"
with:

Code:

./configure --prefix=/home/adm${APPLICATION_NAME}/${APPLICATION_NAME}/tools/clamav --sysconfdir=/home/adm${APPLICATION_NAME}/${APPLICATION_NAME}/tools/clamav/etc --with-user=adm${APPLICATION_NAME} --with-group=adm${APPLICATION_NAME} --disable-clamav --disable-bzip2 --disable-zlib-vcheck --disable-gcc-vcheck CFLAGS="-O0" || error "Could not configure ClamAV"
The relevant change is that I added the options --disable-gcc-vcheck CFLAGS="-O0" which disable the gcc check and disable the gcc compiler optimisations.

3) Now run the ispconfig setup script again.

Why did we not add this by default? The changes above disable the compiler optimisations for gcc, this is not recommended and might slow down clamav.

crypted 26th January 2008 04:49

This error also pertains to the CentOS 5.x branch. The GCC default install is the latest version, 4.1.2, but the error still persists.

I am currently in the middle of ./setup again with the recommended patch and it seems to be installing.


SOLVED: Till's solution does solve the issue with the later versions of some operating systems that include the latest GCC. I can't figure out why this still occurs... It does, such is life. Apply the patch (line replacement in file) and keep on trucking.

wpwood3 26th January 2008 06:39

Quote:

Originally Posted by crypted
This error also pertains to the CentOS 5.x branch. The GCC default install is the latest version, 4.1.2, but the error still persists.

This is absolutely false!

crypted 26th January 2008 07:33

gcc.i386 4.1.2-14.el5 installed
gcc-c++.i386 4.1.2-14.el5 installed

till 26th January 2008 09:38

I added a patch for the next ISPConfig release (its in SVN already) that includes 2 configure statements for clamav. If the first (optimal) configure string fales, it falls back automatically to the second configure string which contains the above fix. Hope this will solve the installation provblems in future updates.

wr19026 4th February 2008 16:26

Quote:

Originally Posted by till
If your ISPConfig 2.2.19 update stops, dont panic. Please check if you see the following error message in the compilation output:



This error may occur if you use a older linux distribution like Ubuntu 6.x, SuSE 10 or Fedora 4 (just a few where I heard about this problem). This problem is caused by the ClamAV script, the ClamAV developers have added a check that prevents the compilation of the latest ClamAV version with some gcc compiler versions which are buggy.

The recommended solution from the ClamAV dev's: Update GCC

The problem is, newer gcc packages are not available anymore for these linux distributions. Older gcc versions may work too, so downgrading gcc can be an option.

I collected here some workarounds:

Ubuntu 6.06 LTS: http://www.howtoforge.com/forums/sho...4&postcount=27

Tried this on an Ubuntu 6.06.2 install and it keeps blowing up with the same error message. Downside is that during the install my complete root/ispconfig/ dir is deleted, but luckily the database and web/user data still exists.

:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 6.06.2 LTS
Release: 6.06
Codename: dapper

It's an up-to-date install and I have followed the steps to install gcc-3.4 and (re)create the /root/ispconfig/ dir

Guess I'll install 2.2.17 which worked fine and will give 2.2.20 a shot; if that also fails I guess I'll have to stick with the last working version.

The error I keep seeing is ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory

Check 4th February 2008 16:41

sounds like the same thing for me as well... I went back to .18 which was working great before the upgrade... It is working again...except nothing is listed on the web app for ispconfig, but all my sites are up..

I have another thread about the sites not being listed if you run into the same thing when you go back to .17

wr19026 4th February 2008 16:48

Quote:

Originally Posted by Check
sounds like the same thing for me as well... I went back to .18 which was working great before the upgrade... It is working again...except nothing is listed on the web app for ispconfig, but all my sites are up..

I have another thread about the sites not being listed if you run into the same thing when you go back to .17

I couldn't verify that the sites are up ut I was able to verify that e-mail could still be sent and received.

Interestingly it recognizes it at the beginning of the install process as an upgrade, so it should restore everything.

The last thing I want to do is a full reinstall of ISPconfig, do the manual setups and then reload the user and web data from backup...

karapuz 22nd February 2008 07:21

compat-gcc-32 workaround in Fedora Core 4 (and possible elsewhere)
 
I was hitting the same problem in FC4.
The only ways to upgrade gcc are to upgrade to FC7 or FC8 using yum (too scarry for me)
or compile GCC from source (this also might hit the GCC bug, so GCC would need to be compiled with gcc compat 3.2)

I desided to give it a try compiling clamav using gcc compat 3.2, seems to work fine so far.
compat-gcc-32.x86_64 3.2.3-47.fc4 installed
compat-gcc-32-c++.x86_64 3.2.3-47.fc4 installed

Just run the following before configure:

export CC=gcc32

then just as you would build it regulary
./configure
make
make install


All times are GMT +2. The time now is 09:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.