HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   dovecot problem - help please! (http://www.howtoforge.com/forums/showthread.php?t=18922)

samoand 2nd January 2008 15:26

dovecot problem - help please!
 
Greetings! I'm trying to configure dovecot on CentOS5.1, and here's where I'm hitting a wall. There are 2 machines: Windows and CentOS
1. I can telnet from CentOS machine to itself using either domain name or ip on port 110 and read all email, no problem. However, I can't do the same from the Windows machine.
2. Probably related to "1", but with a twist. I can't connect from Outlook client; "Test Account Settings" comes back with "Outlook cannot connect to your incoming (POP3) email server". However, test e-mail message from Outlook makes it to the test account and is viewable locally on the CentOS machine. In fact, it's viewable if I telnet to CentOS machine from itself on 110.

Closest setting in dovecot.conf that I found might be a suspect was "listen", it's currently set to default
listen = [::]
I tried to play with it and change it to all variables that would come to mind (ip, domain name, mail server name and combinations thereof) - without any result.
Any thoughts regarding the situation? Thanks.

falko 3rd January 2008 15:47

What are the outputs of
Code:

netstat -tap
and
Code:

iptables -L
? Did you disable SELinux?

samoand 6th January 2008 10:25

Got it.
It was "listen" directive in dovecot.conf, nonetheless.
Replaced default "[::]" with "*" and everything worked. Apparently [::], while tuned to handle IPv6 interfaces, is less reliable for IPv4. My second mistake was trying to play with combinations of domain names and ip-s on that line: it doesn't like multiple entries.
Thanks!


All times are GMT +2. The time now is 04:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.