HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   send mail & Cyrus-imapd (http://www.howtoforge.com/forums/showthread.php?t=1881)

redhatlover 31st December 2005 06:00

send mail & Cyrus-imapd
 
Hi,
Can any one help me with this problem
Does anyone know how to configure sendmail to use cyrus imapd.
(CentOs 4.2)

falko 31st December 2005 13:19

Generally, you have to tell Sendmail that it should deliver emails to Maildir instead of mbox. You could also write procmail recipes that deliver emails to Maildir.
As long as the mails are delivered to Maildir, Cyrus shouldn't have problems.

redhatlover 31st December 2005 15:42

Mail not receive
 
Quote:

Originally Posted by falko
Generally, you have to tell Sendmail that it should deliver emails to Maildir instead of mbox. You could also write procmail recipes that deliver emails to Maildir.
As long as the mails are delivered to Maildir, Cyrus shouldn't have problems.

Hi Falko,
I'm able to send mail outside(sendmail). but I don't receive mails from outside.

my sedmail.mc
dnl # DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl -- THIS ONE ALSO BLOCK

dnl # LOCAL_DOMAIN(`localhost.localdomain')dnl --- THIS ONE ALSO BLOCK

MY virtusertable
@mydoamain.com myuser <<< (this is my catch all user name)


My local-host-names
# local-host-names - include all aliases for your machine here.
mydomain.com

falko 31st December 2005 18:52

Quote:

Originally Posted by redhatlover
my sedmail.mc
dnl # DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl -- THIS ONE ALSO BLOCK

Please try to change that line to
Code:

dnl # DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl
and restart Sendmail. Also have a look here: http://www.howtoforge.com/faq/14_32_en.html

redhatlover 1st January 2006 03:38

Mail not receive
 
Hi Falko,

This is my mail log

31 19:17:02 localhost sendmail[4752]: k010H2wr004752: from=<root@localhost.localdomain>, size=323, class=0, nrcpts=1, msgid=<200601010016.k010Gac4004751@localhost.local domain>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]

Dec 31 19:17:02 localhost sendmail[4751]: k010Gac4004751: to=admin@mydomain.com, ctladdr=root (0/0), delay=00:00:26, xdelay=00:00:00, mailer=relay, pri=30021, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (k010H2wr004752 Message accepted for delivery)
Dec 31 19:17:02 localhost sendmail[4753]: k010H2wr004752: to=<admin@mydomain.com>, ctladdr=<root@localhost.localdomain> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=local, pri=30557, dsn=2.0.0, stat=Sent

Dec 31 19:33:20 localhost sendmail[4768]: k010XJcW004768: from=<redhatlover@hotmail.com>, size=685, class=0, nrcpts=1, msgid=<BAY102-F184D3CC892F2BC78E443C7A32A0@phx.gbl>, proto=ESMTP, daemon=MTA, relay=bay102-f18.bay102.hotmail.com [64.4.61.28]

Dec 31 19:33:20 localhost sendmail[4769]: k010XJcW004768: to=<admin@mydomain.com>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=30892, dsn=2.0.0, stat=Sent

Dec 31 19:36:23 localhost pop3[4313]: accepted connection
Dec 31 19:36:23 localhost master[4835]: about to exec /usr/lib/cyrus-imapd/pop3d
Dec 31 19:36:23 localhost pop3[4835]: executed
Dec 31 19:36:23 localhost pop3[4313]: badlogin: [192.168.2.38] plaintext

redhatlover SASL(-1): generic failure: checkpass failed
Dec 31 19:37:26 localhost master[2718]: process 4313 exited, status 0


why my popuser(catch all) password fail everytime? (I used right password)

falko 1st January 2006 13:54

Did you use the correct user?

redhatlover 1st January 2006 16:20

mail
 
Quote:

Originally Posted by falko
Did you use the correct user?

yes correct user and pass word


All times are GMT +2. The time now is 09:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.