HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Need some help with ispconfig errors (http://www.howtoforge.com/forums/showthread.php?t=18601)

kadi 20th December 2007 02:17

Need some help with ispconfig errors
 
hello
I installed debian etch and followed the perfect setup, then installed ispconfig 2.2.18.
I have some issues with ispconfig:
I deleted ARecord & CNAME because i was having problem with dns is not
resolving to the domain name and still, when i try to add them again i got
an error on Arecord after i try to save " There is already a CNAME Record entry for this host in this zone." then i tried to add CNAME and got this : "There is already ARecord entry for this host in this zone."
I checked all recyclebins nothing in it.
I read on a post here you can delete it from the database table dns_a but i don't know how to
find it or where it is .
Another issue is when i empty the recycle bin and try to check it after long
time it says that it still updating the system please wait a while and try again.
The last issue is: proftpd server was working fine and today i was trying to
check the servers and it says FTP server offline , i try to run it from the shell
and said failed, is this may be because i changed the IP ?
Thanks any help will be appreciated.
:)

till 20th December 2007 09:46

Please empty the recycle bin in the dns manager.

To your ftp problem, please configure proftpd to listen also on the IP 127.0.0.1

kadi 20th December 2007 21:31

Thanks till for your help
 
hello till
thanks for your response.
I tried to empty the recyclebin on dns, like i mensioned above and it gives me
the same error, so i found dns_a and took it out from their (phpmyadmin ispconfigdb table dns_a) even doing that did not stop the same errors.
concerning proftpd the listen to IP 127.0.0.1 how to do that ? i mean what to write ? , what is weird is last time that happen i installed it and take it out like 10 times untill it works, and my host file which it could be the reason is correct with server name and IP.
As a final solution i thought to uninstall ispconfig and reinstall after installing
proftpd first, if this will solve the problem.
another simple question i rather to ask it here instead of posting
a new one:
myserver is just for me no resellers no clients no customers, so
where will be the best place to put the sites ? like under admin, sites ?
+ i don't see the file manager folder anywhere ? or i have to create
the folder file manager ?
Thanks very much for your help.

falko 21st December 2007 14:03

Quote:

Originally Posted by kadi
myserver is just for me no resellers no clients no customers, so
where will be the best place to put the sites ? like under admin, sites ?

At least you must create one customer (this can be yourself); you can create it under admin and then place the web sites in the Sites folder.

kadi 21st December 2007 20:48

Thanks
 
hello again
Thanks for your response again.
OK i have a question :
in the ISPConfig DNS manager under the tab : Domain & ARecord & CNAME
which IP address should the one from the router:192.168.x.x or the system
IP 97.312.XX.XX ?
also I don't see File Manager folder ?
Thanks again

falko 22nd December 2007 17:04

For DNS records use your router's public IP address.

kadi 23rd December 2007 03:44

Thanks for your reply
 
hello
Thanks for your reply.
I got tired of proftpd trying to install it so many time and it didn't work, so
i installed vsftpd instead, and i follow the setup instructions to make it secure
with mysql, now i created a /home/vsftpd/user like the instructions said and was able to upload files in ispconfig , my question is :
when i upload a new index ,it didn't show because ispconfig set the directory
different , where am i suppose to put my sites files on the sever in which
directory? if i put it like what ispconfig.conf said /var/www/web1/web
i can't upload it because vsftpd use /home/vsftpd/username/site ?
how can i slove this problem ?
Thanks again very much:)

falko 23rd December 2007 18:28

The vsftpd with MySQL setup is incompatible with ISPConfig because ISPConfig uses system users, not virtual users.

kadi 23rd December 2007 20:31

Thanks and happy holidays
 
hello
thanks and happy holidays , now after i made this mistake, what should i do
to correct it ? like remove it then reinstall ? and how to remove it from mysql?
i need some instructions to clean the mess , also please if you have any link
for instructions on how to configure it with ispconfig.
Thanks again and happy holidays.:)

till 24th December 2007 14:21

FTP does not have to be configured to work with ISPConfig, it works right out of the box with the configurtaion that comes with the linux distribution.

I recommend that you uninstall FTP including all config files and then reinstall it as described in the perfect setup guide for your linux distribution.


All times are GMT +2. The time now is 07:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.