HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Firefox and flash player issue! (http://www.howtoforge.com/forums/showthread.php?t=18529)

mrwasabi 18th December 2007 01:39

Firefox and flash player issue!
 
Hello folks,
I've recently upgraded to Ubuntu 7.1, ran all the required updates, Ubuntu restricted and so forth, and I cannot view flash websites! I've tried reinstalling flash and it does no good, any ideas why this is happening? TIA

BTW the same thing happens with Opera, flash will not work.

falko 18th December 2007 18:36

Please type
Code:

about:plugins
in the address bar of Firefox. IS the Flash Player listed in the list of plugins that appears?

mrwasabi 18th December 2007 19:15

Flash and Firefox
 
Ok I determined that it was the flash player in the repo that was the problem, it's a bad version! I removed flash first of all:
sudo apt-get remove flashplugin-nonfree gnash

Then I downloaded a different flash player:
http://fpdownload.macromedia.com/get...p9_archive.zip

I unzipped the archive:
tar -zxvf install_flash_player_9_linux.tar.gz
Or simply right click the archive in the folder where you downloaded it and select "extract", then point it to the folder where you wish to save it.

Then I installed the new version of flash player by simply navigating to the correct folder, there are several versions in this archive so select the appropriate one for your OS.
I saved mine in the documents folder, 9r48 is for linux: /documents/fp9_archive/9r48/install_flash_player_9_linux
sudo ./flashplayer-installer
You'll be asked for the install path, for firefox it's:
/usr/lib/firefox/

Then I launched firefox and flash now works!

textonyx 21st December 2007 13:46

Flash and Firefox
 
Hi,
I intended just to drop falko a line thanking him for the work he did on the
tutorial, especially providing all those time-consuming pictures. VMware and
f-stop were also on the list of packages to install and I wanted to learn how
to use them. I had just tried out Kubuntu and it took me 35 minutes to install
Flash, so I was looking for an easier approach than having to enable the
multiverse repository. Thanks also for the VMware pointer on tut. page 5.

I went to the Macromedia website and downloaded the current flash*tar.gz
which I unpacked in /home/ubuntu/downloads into the same directories that
mrwasabi recounted for Flash. I ran flash-install from the command line which
I thought would be the same as terminal, but it didn't work until I switched
to terminal which was available in the command line option window. I saw it
install although as I didn't use sudo it just installed for the user logged in, me.
When I went back to the Macromedia site with Firefox (which was easy to
install) flash and sound just worked without any more ado. Thanks for the

Tutorial,
Techtonics


All times are GMT +2. The time now is 02:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.