HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Mail not working (http://www.howtoforge.com/forums/showthread.php?t=1838)

Roadracer 27th December 2005 22:35

Mail not working
 
Not sure what is happening. Any help would be appriciated. I have installed phpBB2 on my site and just to test the email system, I tried to send something via the website. I didn't get any mail. Here is some of the maillog.

Quote:

Dec 27 14:59:04 server postfix/qmgr[2470]: 41A0891378B: from=<apache@server.roadracers.org>, size=1541, nrcpt=1 (queue active)
Dec 27 14:59:12 server postfix/smtp[21535]: 41A0891378B: to=<david.hennessy@qwest.com>, relay=uswgco33.uswest.com[199.168.32.122], delay=1636, status=bounced (host uswgco33.uswest.com[199.168.32.122] said: 553 5.1.8 <david.hennessy@qwest.com>... Domain of sender address apache@server.roadracers.org does not exist (in reply to RCPT TO command))
Dec 27 14:59:12 server postfix/cleanup[21538]: A769891378A: message-id=<20051227205912.A769891378A@server.roadracers.o rg>
Dec 27 14:59:12 server postfix/qmgr[2470]: A769891378A: from=<>, size=3672, nrcpt=1 (queue active)
Dec 27 14:59:12 server postfix/qmgr[2470]: 41A0891378B: removed
Dec 27 14:59:12 server postfix/local[21539]: A769891378A: to=<root@server.roadracers.org>, orig_to=<apache@server.roadracers.org>, relay=local, delay=0, status=sent (delivered to mailbox)
Dec 27 14:59:12 server postfix/qmgr[2470]: A769891378A: removed
Not sure if its the server or my error in setting up phpBB. Sorry if this turns out to my my error in setting up phpBB.

Just added the webmail pkg. to test that, install worked, but can't log into it.

ZyanKLee 27th December 2005 23:05

has it been this message:
Quote:

Dec 27 14:59:12 server postfix/smtp[21535]: 41A0891378B: to=<david.hennessy@qwest.com>, relay=uswgco33.uswest.com[199.168.32.122], delay=1636, status=bounced (host uswgco33.uswest.com[199.168.32.122] said: 553 5.1.8 <david.hennessy@qwest.com>... Domain of sender address apache@server.roadracers.org does not exist (in reply to RCPT TO command))
Dec 27 14:59:12 server postfix/cleanup[21538]: A769891378A: message-id=<20051227205912.A769891378A@server.roadracers.o rg>
there seems to be a problem with the domain of your server, maybe the dns-settings were recently changed. perhaps the mailserver where your email went to could not look up the domain and therefore didn't accept the mail ?

but I am only a little noob, falko or till might know more about this case

till 28th December 2005 11:30

I gues server.roadracers.org is the hostname of your ISPConfig server? ZyanKLee is right, the domain server.roadracers.org does not exits in DNS. Please create an A or CName record for server.roadracers.org in the authoritive nameserver for the domain roadracers.org pointing to your server.

Roadracer 28th December 2005 20:43

Is there a way to change the mail to point to another server? I haven't moved roadracers.org onto the server until I know everything works. I do have defendersguild.org running on the server and all the DNS is pointing to the right spot.

Otherwise I will rebuild the server again with the right information.

till 28th December 2005 22:16

You dont have to rebuild the server. Just set the hostname of the server to the other domain. Which linux distribution do you use?

Roadracer 28th December 2005 22:34

Fedora Core 4

falko 28th December 2005 23:30

I suggest that you either create an A record for server.roadracers.org pointing to your server or replace server.roadracers.org with server.defendersguild.org (and create an A record for it). You 'd then have to replace server.roadracers.org in /etc/hosts, /etc/hostname (
Code:

echo server.defendersguild.org > /etc/hostname
/bin/hostname -F /etc/hostname

), /etc/postfix/main.cf (restart Postfix afterwards), maybe your Apache configuration (restart Apache afterwards), etc.

Roadracer 29th December 2005 01:14

Thanks Till and Falko for helping me with this. It looks like somethings are working now but I have not gotten any emails. The first email looks like it got bounced for a IP on a banned list, the second I am not sure why I didn't get the mail. Here is the log now, it will make more sense to you.

Quote:

Dec 28 18:04:23 server sendmail[8603]: jBT04NVj008603: from=apache, size=1077, class=0, nrcpts=1, msgid=<46b3e9ea98fd21177d79ef3c6cf02142@www.defend ersguild.org>, relay=apache@localhost
Dec 28 18:04:23 server postfix/smtpd[8604]: connect from server.defendersguild.org[127.0.0.1]
Dec 28 18:04:23 server postfix/smtpd[8604]: setting up TLS connection from server.defendersguild.org[127.0.0.1]
Dec 28 18:04:23 server postfix/smtpd[8604]: TLS connection established from server.defendersguild.org[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Dec 28 18:04:23 server sendmail[8603]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Dec 28 18:04:23 server postfix/smtpd[8604]: 9BC329137B7: client=server.defendersguild.org[127.0.0.1], sasl_sender=apache@server.defendersguild.org
Dec 28 18:04:23 server postfix/cleanup[8605]: 9BC329137B7: message-id=<46b3e9ea98fd21177d79ef3c6cf02142@www.defenders guild.org>
Dec 28 18:04:23 server postfix/qmgr[8361]: 9BC329137B7: from=<apache@server.defendersguild.org>, size=1529, nrcpt=1 (queue active)
Dec 28 18:04:23 server sendmail[8603]: jBT04NVj008603: to=david.hennessy@qwest.com, ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31077, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 9BC329137B7)
Dec 28 18:04:23 server postfix/smtpd[8604]: disconnect from server.defendersguild.org[127.0.0.1]
Dec 28 18:04:24 server sendmail[8607]: jBT04NCZ008607: from=apache, size=927, class=0, nrcpts=1, msgid=<f939724e7dc9980fc5283034c9eef4d8@www.defend ersguild.org>, relay=apache@localhost
Dec 28 18:04:24 server postfix/smtpd[8604]: connect from server.defendersguild.org[127.0.0.1]
Dec 28 18:04:24 server postfix/smtpd[8604]: setting up TLS connection from server.defendersguild.org[127.0.0.1]
Dec 28 18:04:24 server postfix/smtpd[8604]: TLS connection established from server.defendersguild.org[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Dec 28 18:04:24 server sendmail[8607]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Dec 28 18:04:24 server postfix/smtpd[8604]: 3A7C69137B8: client=server.defendersguild.org[127.0.0.1], sasl_sender=apache@server.defendersguild.org
Dec 28 18:04:24 server postfix/cleanup[8605]: 3A7C69137B8: message-id=<f939724e7dc9980fc5283034c9eef4d8@www.defenders guild.org>
Dec 28 18:04:24 server postfix/qmgr[8361]: 3A7C69137B8: from=<apache@server.defendersguild.org>, size=1375, nrcpt=1 (queue active)
Dec 28 18:04:24 server sendmail[8607]: jBT04NCZ008607: to=webmaster@roadracers.org, ctladdr=apache (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=30927, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 3A7C69137B8)
Dec 28 18:04:24 server postfix/smtpd[8604]: disconnect from server.defendersguild.org[127.0.0.1]
Dec 28 18:04:24 server postfix/cleanup[8605]: 4D1C99137B5: message-id=<f939724e7dc9980fc5283034c9eef4d8@www.defenders guild.org>
Dec 28 18:04:24 server postfix/qmgr[8361]: 4D1C99137B5: from=<apache@server.defendersguild.org>, size=1521, nrcpt=1 (queue active)
Dec 28 18:04:24 server postfix/local[8610]: 3A7C69137B8: to=<webmaster@roadracers.org>, relay=local, delay=0, status=sent (forwarded as 4D1C99137B5)
Dec 28 18:04:24 server postfix/qmgr[8361]: 3A7C69137B8: removed
Dec 28 18:04:29 server postfix/smtp[8606]: 9BC329137B7: to=<david.hennessy@qwest.com>, relay=uswgco33.uswest.com[199.168.32.122], delay=6, status=bounced (host uswgco33.uswest.com[199.168.32.122] said: 550 5.7.1 <david.hennessy@qwest.com>... Rejected: 66.41.245.69 listed at http://www.mail-abuse.com/enduserinfo.html (in reply to RCPT TO command))
Dec 28 18:04:29 server postfix/cleanup[8605]: 593209137B8: message-id=<20051229000429.593209137B8@server.defendersgui ld.org>
Dec 28 18:04:29 server postfix/qmgr[8361]: 593209137B8: from=<>, size=3722, nrcpt=1 (queue active)
Dec 28 18:04:29 server postfix/qmgr[8361]: 9BC329137B7: removed

Roadracer 29th December 2005 01:25

I also noted this in the /etc/postfix/virtusertable

Quote:

webmaster@www.defendersguild.org web2_webmaster
web2_webmaster@www.defendersguild.org web2_webmaster
@www.defendersguild.org web2_webmaster
webmaster@defendersguild web2_webmaster
web2_webmaster@defendersguild web2_webmaster
@defendersguild web2_webmaster
.org is missing on some of the entries, is this correct or a mistake?

till 29th December 2005 09:08

Please check the Co-Domain of the website www.defendersguild.org if the .org ending is missing.


All times are GMT +2. The time now is 20:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.