HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   SMTP authentication problem (http://www.howtoforge.com/forums/showthread.php?t=18372)

mphayesuk 12th December 2007 22:45

SMTP authentication problem
 
Ok guys I am using Debian as per the perfect setup guide and have a slight problem when send mail from a mail client (ie Outlook Express) send mail from the webmail appliacation is fine.

I have enabled the "Server requires authentication" but keep getting asked to enter my credentials even though I know the ones I am using are corrent (web24_bob with the corrent password)

I get the following in my mail.log file


WebServ01:/var/log# tail mail.log
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: warning: SASL authentication pro blem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: warning: unknown[212.xxx.xxx.xxx]: SASL LOGIN authentication failed: authentication failure
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: lost connection after AUTH from unknown[212.xxx.xxx.xxx]
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: disconnect from unknown[212.xxx. xxx.xxx]
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: connect from unknown[212.xxx.xxx. xxx]
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: warning: SASL authentication pro blem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: warning: SASL authentication pro blem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: warning: unknown[212.x.x.x]: SASL LOGIN authentication failed: authentication failure
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: lost connection after AUTH from unknown[212.x.x.x]
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: disconnect from unknown[212.x. x.x]
WebServ01:/var/log# clear
WebServ01:/var/log# tail mail.log
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: warning: unknown[212.x.x.x]: SASL LOGIN authentication failed: authentication failure
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: lost connection after AUTH from unknown[212.x.x.x]
Dec 12 21:35:37 WebServ01 postfix/smtpd[31324]: disconnect from unknown[212.x.x.x]
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: connect from unknown[212.x.x.x]
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: warning: unknown[212.xxx.xxx.xxx]: SASL LOGIN authentication failed: authentication failure
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: lost connection after AUTH from unknown[212.xxx.xxx.xxx]
Dec 12 21:35:40 WebServ01 postfix/smtpd[31324]: disconnect from unknown[212.xxx.xxx.xxx]
WebServ01:/var/log#

Thanks
Martin

mphayesuk 12th December 2007 23:01

I do get the following added lines at the end of my main.cf file, but I dont think it makes a difference.


virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

mphayesuk 13th December 2007 11:33

Found the problem
 
Ok after sleeping on it and looking at it with fresh eyes I have found my mistake

postconf -e 'smtpd_sasl_local_domain ='
postconf -e 'smtpd_sasl_auth_enable = yes'
postconf -e 'smtpd_sasl_security_options = noanonymous'
postconf -e 'broken_sasl_auth_clients = yes'
postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination'
postconf -e 'inet_interfaces = all'
echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf
echo 'mech_list: plain login' >> /etc/postfix/sasl/smtpd.conf

the above is an extract taken from the Debian 4 perfect setup guide, on the webpage/website the font is not the best one as the "w" in pwcheck looks like a "v".

Perhaps a change of font could be a better option for future guides or perhaps I need a pair of glasses.

Thanks
Martin


All times are GMT +2. The time now is 06:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.