HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   BackupPC/SSH Error (http://www.howtoforge.com/forums/showthread.php?t=17870)

n74jw 30th November 2007 19:19

BackupPC/SSH Error
 
Hello - I followed Falko's tutorial on how to set up backuppc on Debian (I used Ubuntu) and everything went great except for the first backup of my Ubuntu desktop. I think there is an SSH error somewhere, but I do not know SSH all that well. The tunnel creation process went fine, with the last part not asking me for a password and displaying 'root'.

Here is the XFer Log

full backup started for directory /
Running: /usr/bin/ssh -q -x -l root judas /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --recursive --ignore-times . /
Xfer PIDs are now 6158
Read EOF: Connection reset by peer
Tried again: got 0 bytes
Done: 0 files, 0 bytes
Got fatal error during xfer (Unable to read 4 bytes)
Backup aborted (Unable to read 4 bytes)


Where did I go wrong?

Thanks

falko 1st December 2007 13:07

Did you take a look at the logs on the client?

brunus 19th December 2007 11:25

hi,
sam problem here: I followed the how to religiously and it's working for my client, except that I'd like to back up the localhost as well and then I get the:
...
Got fatal error during xfer (Unable to read 4 bytes)
Backup aborted (Unable to read 4 bytes)

the only difference with regards to the tutorial is that I've changed the TopDir variable to my external usb disk (/media/disk/backup) instead of creating a new partition on my server, and of course I've excluded that folder from the backup ones.

I did check the permissions on both the config files and the destination directory and they are both owned by backuppc who's also the user for localhost.

I don't know what I'm missing here....

thanks in advance,

brunus

rozilla 28th October 2008 21:09

I have this same problem. One thing I've noticed is on the server as user backuppc when I run

Code:

ssh -l root clientIP whomai
the reply is

Code:

root
However, when I go by hostname

Code:

ssh -l root clientHostName
It prompts the root for a password. Any ideas?

rozilla 28th October 2008 21:41

Nevermind. I found the problem. There was a change of IPs for server and client a month ago, and a "rechange" a few days ago. Added the IP to /etc/hosts and recreated the public/private key exchanges, and all is fine now.

For those who are always prompted for a password, try this

Code:

ssh -l root clientIP whoami

and


ssh -l root clientHostName whoami

clientIP: e.g 198.162.2.100
clientHostname: e.g. mediaserver

One of the two should return

Code:

root
while the other returns

Code:

The authenticity of host 'files (198.162.2.123)' can't be established.
RSA key fingerprint is 67:3f:82:e4:1c:6a:71:b8:46:f3:8f:a0:28:c6:f2:25.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'mediaserver' (RSA) to the list of known hosts.

root

After that, run your backup and it should work just mine.

iosix 14th March 2012 18:44

Backup aborted (Unable to read 4 bytes)
 
Asegurate que el host que tiene instalado el servicio BackupPC tenga un nombre distinto a localhost. Cambia esto en el archivo /etc/hosts
Ejemplo:
# Do not remove the following line, or various programs
# that require network functionality will fail.
IPYOUHOST backuppc (nombre del host)
127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6

-------------------------------------------------------------------------------
Luego recien crea las firmas digitales y copias las firmas a los host remotos a backapear.


All times are GMT +2. The time now is 18:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.