HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   DNS problem with email (http://www.howtoforge.com/forums/showthread.php?t=17833)

drmeg 29th November 2007 19:30

DNS problem with email
 
I think I have a DNS problem with my emails.

I host several sites with ispconfig 2.2.18 on ubuntu 6.06 LTS using the perfect setup instructions.

All my hosted websites seem to work properly and are accessible from the web. All my hosted users can send email to anyone on the web, but can only receive email from each other.

When I DIG the MX record I get the following:

root@ws1:~# dig cslive.net mx

; <<>> DiG 9.3.2 <<>> cslive.net mx
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63686
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;cslive.net. IN MX

;; ANSWER SECTION:
cslive.net. 85015 IN MX 10 cslive.net.

;; ADDITIONAL SECTION:
cslive.net. 85015 IN A 71.41.166.18

;; Query time: 35 msec
;; SERVER: 204.117.214.10#53(204.117.214.10)
;; WHEN: Thu Nov 29 11:59:43 2007
;; MSG SIZE rcvd: 60


I think I am missing an A-record for the mail, right?
Can I fix this with ispconfig, or do I have to edit my named.conf manually?

msource 29th November 2007 19:53

I,

You have to create a A record like this ex:
mail A 71.41.166.18

On the MX record you have to altered for ex:
mail.cslive.net

Did you understand?

Do a DIG on liz-online.pt and you will figured out.

You could add me to gtalk in m2source@gmail.com, or leave an e-mail if you need any help.

drmeg 30th November 2007 11:17

Thanks for the help.
I added the A-record and now the DIG looks like this:

root@ws1:/# dig cslive.net mx

; <<>> DiG 9.3.2 <<>> cslive.net mx
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36034
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;cslive.net. IN MX

;; ANSWER SECTION:
cslive.net. 85322 IN MX 10 mail.cslive.net.

;; ADDITIONAL SECTION:
mail.cslive.net. 85322 IN A 71.41.166.18

;; Query time: 27 msec
;; SERVER: 204.117.214.10#53(204.117.214.10)
;; WHEN: Fri Nov 30 04:10:34 2007
;; MSG SIZE rcvd: 65


It looks like it should be working, but it still is not.
Messages are still not being received from other servers .

Any ideas?

till 30th November 2007 12:26

Changes in DNS may take up to 48 hours to propagate.


All times are GMT +2. The time now is 07:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.