HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Problem with Webmail URL, uses local network and not internet (http://www.howtoforge.com/forums/showthread.php?t=1778)

danf.1979 22nd December 2005 02:47

Problem with Webmail URL, uses local network and not internet
 
Hi to all:
I'm having problems to login to webmail, check this url: https://192.168.0.1:81/webmail/
I cant login from other machines than from my personal one. How can I change 192.168.0.1 to my internet IP?
Many thanks

falko 22nd December 2005 09:53

First, you must use the same URL that's in /home/admispconfig/ispconfig/lib/config.inc.php (with /webmail appended).

If you want to use your public IP address, put it into /home/admispconfig/ispconfig/lib/config.inc.php and forward port 81 from your router to your ISPConfig system.

Quote:

I'm having problems to login to webmail, check this url: https://192.168.0.1:81/webmail/
We can't check that URL because it's using a private IP address that noone outside your local network can access.

danf.1979 23rd December 2005 00:34

My config.inc.php
Code:

<?

/*

Copyright (c) 2005, projektfarm Gmbh, Till Brehm, Falko Timme

All rights reserved.



Redistribution and use in source and binary forms, with or without modification,

are permitted provided that the following conditions are met:



    * Redistributions of source code must retain the above copyright notice,

      this list of conditions and the following disclaimer.

    * Redistributions in binary form must reproduce the above copyright notice,

      this list of conditions and the following disclaimer in the documentation

      and/or other materials provided with the distribution.

    * Neither the name of ISPConfig nor the names of its contributors

      may be used to endorse or promote products derived from this software without

      specific prior written permission.



THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND

ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED

WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.

IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,

BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,

DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY

OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING

NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,

EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

*/

// Register Globals emulieren, falls notwendig

if(get_cfg_var('register_globals') != 'On') {



    foreach($HTTP_GET_VARS as $getkey => $getval) {

        $$getkey = $getval;

    }

    unset($getkey);

    unset($getval);



    foreach($HTTP_POST_VARS as $postkey => $postval) {

        $$postkey = $postval;

    }

    unset($postkey);

    unset($postval);



    foreach($HTTP_COOKIE_VARS as $cookiekey => $cookieval) {

        $$cookiekey = $cookieval;

    }

    unset($cookiekey);

    unset($cookieval);

}



$go_info = array();



$s = $HTTP_GET_VARS["s"];

if(isset($HTTP_POST_VARS["s"])) $s = $HTTP_POST_VARS["s"];

$s = addslashes($s);

$session = "s=$s";

$set_header = 1;

@session_start();



/**********************************************

* System Settings

**********************************************/



$go_info["server"]["dir_trenner"] = "/";

$go_info["server"]["server_root"] = "/home/admispconfig/ispconfig";

$go_info["server"]["server_url"] = "https://www.mundohosting.cl:81";

$go_info["server"]["include_root"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."lib";

$go_info["server"]["classes_root"] = $go_info["server"]["include_root"] . $go_info["server"]["dir_trenner"] ."classes";

$go_info["server"]["temp_dir"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."temp";

$go_info["server"]["files_dir"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."files";

$go_info["server"]["backup_dir"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."backup";

$go_info["server"]["version"] = "2.1.1";

$go_info["server"]["os"] = "linux";

$go_info["server"]["ort"] = "local";

$go_info["server"]["banner"] = "0";

$go_info["server"]["db_host"] = "localhost";

$go_info["server"]["db_name"] = "isp_config";

$go_info["server"]["db_user"] = "root";

$go_info["server"]["db_password"] = "this_is_not_my_password_lol";

$go_info["server"]["db_type"] = "mysql";

$go_info["server"]["mail_server"] = "";

$go_info["server"]["mail_user"] = "";

$go_info["server"]["mail_password"] = "";

$go_info["server"]["smtp_server"] = "localhost";

$go_info["server"]["mode"] = "";

$go_info["server"]["lang"] = "es";



$go_info["server"]["postfix_config"] = 1; // 1 = SENDMAIL-STYLE, 2 = POSTFIX-STYLE

$go_info["server"]["smtp_restart"] = 1; // 1 = stop/start, 2 = restart

$go_info["server"]["network_config"] = 0; // 0 = none, 1 = automatic



/**********************************************

* Tools Settings

**********************************************/



$go_info["tools"]["zip"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."tools".$go_info["server"]["dir_trenner"]."zip".$go_info["server"]["dir_trenner"]."zip"; // nicht gzip !!

$go_info["tools"]["unzip"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."tools".$go_info["server"]["dir_trenner"]."unzip".$go_info["server"]["dir_trenner"]."unzip";

$go_info["tools"]["imagemagick"]["mogrify"] = "mogrify.exe";



/**********************************************

* Themes Settings

**********************************************/



// Themes Section

$go_info["theme"]["sitename"] = "ISPConfig";

$go_info["theme"]["page"]["box_color"] = "E4E4E4"; // z.B. E4E4E4 , angaben ohne #

$go_info["theme"]["page"]["nav_color"] = "E0E0E0"; // z.B. 025CCA , angaben ohne #

// Die Logo-Datei muss im Verzeichnis /home/admispconfig/ispconfig/web/design/default liegen!

$go_info["theme"]["page"]["logo"] = ""; // z.B. meinlogo.gif



/**********************************************

* Logging

**********************************************/



$go_info["server"]["log_level"] = 0; // 0 = Debug, 1 = Info, 2 = Warning, 3 = Failure

$go_info["server"]["log_file"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."ispconfig.log"; // Logdatei

if(is_file("/home/admispconfig/ispconfig/adminmail.txt")){

  $go_info["server"]["log_mail"] = trim(shell_exec("cat /home/admispconfig/ispconfig/adminmail.txt")); // Log Emailadresse

} else {

  $go_info["server"]["log_mail"] = "root@localhost";

}

$go_info["server"]["log_device"] = "FILE"; // FILE, SYSTEM, MAIL



/**********************************************

* Demo Mode Settings

**********************************************/



$go_info["demo"]["web_path"] = "";

?>

I think its OK isnt it?
Now, If I do a search for the string "192.168.0.1" in /home/admispconfig/ispconfig/web/webmail/ I get cero results. If I look for "localhost" in the same directory I get:
Code:

/home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau.php:17:        var $mail_server                = "localhost";
/home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau.php:22:        var        $mail_email                        = "unknown@localhost";
/home/admispconfig/ispconfig/web/webmail/inc/class.smtp.php:20:        var $From                                = "root@localhost";
/home/admispconfig/ispconfig/web/webmail/inc/class.smtp.php:32:        var $Host        = "localhost";
/home/admispconfig/ispconfig/web/webmail/inc/class.smtp.php:725:            $host = "localhost";
/home/admispconfig/ispconfig/web/webmail/inc/class.smtp.php:760:            $host = "localhost";
/home/admispconfig/ispconfig/web/webmail/inc/config.php:47: $smtp_server = "localhost";  #YOU NEED CHANGE IT !!
/home/admispconfig/ispconfig/web/webmail/inc/config.php:159:        "domain" => "localhost",
/home/admispconfig/ispconfig/web/webmail/inc/config.php:160:        "server" => "localhost",
/home/admispconfig/ispconfig/web/webmail/inc/config.php:186: $default_mail_server        = "localhost";

I guess I have to modify some of thos "localhost" to "mydomain.tld" or "www.mydomain.tld"?
Thanks for your time.

falko 23rd December 2005 10:00

You must use https://www.mundohosting.cl:81/webmail to access webmail!
Of course, you must forward port 81 from your router to your ISPConfig system.

danf.1979 23rd December 2005 21:52

Yes I know, but when I put https://www.mundohosting.cl:81/webmail the browser tells me there is a problem with the SSL certificate and suddenly I'm on https://192.168.0.1:81/webmail/ (!)
Try it yourself please if you have the the time: https://www.mundohosting.cl:81/webmail
Thanks for your patience...
Daniel.

till 24th December 2005 11:28

Please dont forget that several thousand users including falko and me are using ISPConfig + uebimiau without modifications, so it must be a configuration issue that can be solved without changing any code.

I guess you have installed ISPCOnfig with an IP instaed of the domain name abd the IP address in the ISPConfig httpd.conf/root/ispconfig/httpd/conf/httpd.conf in the vhost is still there but you now use the domain.

falko 24th December 2005 12:17

Quote:

Originally Posted by danf.1979
Try it yourself please if you have the the time: https://www.mundohosting.cl:81/webmail

When I try to connect to that URL, I see the certificate warning at first, which is ok, but then suddenly my browser tries to connect to 192.168.0.1, which cannot work from outside your network.

When I try to connect to https://www.mundohosting.cl:81, I get the normal ISPConfig login screen, so that seems to work, and your problem seems to be related to webmail only.

Did you change the source code of the webmail package in some way?

danf.1979 24th December 2005 16:02

No :(
In facto I've read another post about uninstalling webmail with:
Code:

rm -rf /home/admispconfig/ispconfig/web/webmail
rm -rf /home/admispconfig/ispconfig/web/tools/tools/webmail
rm -rf /home/admispconfig/ispconfig/temp/webmail

And then reinstalled with the update manager. Same thing.
Quote:

Originally Posted by till
I guess you have installed ISPCOnfig with an IP instaed of the domain name abd the IP address in the ISPConfig httpd.conf/root/ispconfig/httpd/conf/httpd.conf in the vhost is still there but you now use the domain.

Your guess is right, I'll check on that file. Many thanks.

danf.1979 24th December 2005 16:24

Excelent! You were right Till. Thank you thank you thank you.
in /root/ispconfig/httpd/conf/httpd.conf I changed to:
Code:

<VirtualHost _default_:81>

#  General setup for the virtual host
DocumentRoot "/home/admispconfig/ispconfig/web"
ServerName www.mundohosting.cl
ServerAdmin root@mundohosting.cl
ErrorLog /root/ispconfig/httpd/logs/error_log
TransferLog /root/ispconfig/httpd/logs/access_log

And everything is OK now!
Many thanks for your support.


All times are GMT +2. The time now is 22:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.