HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   URGENT! Ispconfig stopped worked from a distro upgrade (http://www.howtoforge.com/forums/showthread.php?t=17537)

roboto 21st November 2007 12:09

URGENT! Ispconfig stopped worked from a distro upgrade
 
Hi, to all

I upgraded last night my ubuntu from dapper to feisty. At first everything was fine but then i discovered that ispconfig was dead, i thought a simply upgrade would be ok... wrong. since i start the upgrade the ispconfig installation directory in the /root has benn deleted.

i managed to get apache working commenting out the ispconfig custom log in apache2.conf. the problem is that the email aren't delivered to Mildir. From the mail logs everything seems fine, no errors or warning but nothing is delivered.

so, how can i fix this with or withiut Ispconfig?
a new installation will remove my site, emails account, mysql records.. or it will keeps everything like an upgrade?

PLease answer, it's UUUUUUURGENT!!!

till 21st November 2007 20:38

please run:

mkdir /root/ispconfig
ln -sf /bin/bash /bin/sh

and then unpack the ispconfig installer again and run the setup script.

roboto 21st November 2007 20:54

yep, the upgrade process has started but then i get theese errors:

Code:

./configure:Error: APACI failed
ERROR: Could not configure Apache
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!


till 21st November 2007 20:55

Please post the errors before the line:

./configure:Error: APACI failed

roboto 21st November 2007 21:30

i found the answer in another post
http://www.howtoforge.com/forums/showthread.php?t=9582&

i thought symlinking sh wasn't necessary :)

now i'm testing....

till 21st November 2007 21:46

Thats why I ppsted two commands ;)

roboto 21st November 2007 22:33

still doesn't work. At the end of the installation procedure i get this

Code:

Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.


roboto 21st November 2007 22:35

and also

Code:

root@mondo:~/install_ispconfig # /etc/init.d/ispconfig_server restart
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Shutting down ISPConfig system...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
ISPConfig system stopped!
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Starting ISPConfig system...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
ISPConfig system is now up and running!


roboto 21st November 2007 23:12

i copied de server.crt and server.key into /ispconfig/httpd/conf/ and it works.

thanx for the help :)


All times are GMT +2. The time now is 08:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.