HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Kernel Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=6)
-   -   problem with new kernel (http://www.howtoforge.com/forums/showthread.php?t=1706)

binary_dreamer 16th December 2005 19:00

problem with new kernel
 
hi there.
i am running debian's stable codenamed Sarge. i followed the tutorial from http://www.howtoforge.com/forums/showthread.php?t=21
about installing a new kernel. after that when i boot the system to the new kernel all i get is:
VFS: cannot open root device "hda5" or unknown-block (0,0)
please append a correct "root=" boot option
kernel panic - not syncing : VFS :unable to mount root fs on unknown -block(0,0)

falko 17th December 2005 14:16

Can you post the contents of /boot/grub/menu.lst and /etc/fstab?

Januss 22nd January 2006 21:32

Is your root FS built into the kernel.
 
Had the same problem with 2.6.8.
Adding initrd.img-2.6.8 to menu.lst didn't help, just leaded to the next error:
/dev/console not found.
I think that the solution to my problem was - compiling the root filesystem (where / is mounted, for me it was ext3) support in the kernel. I am not 100% sure, because I changed kernel .config quite alot, but I think that this was the main problem.

P.S. Maybe I'm wrong. but then again.. maybe im not.
Hope this helps someone.


All times are GMT +2. The time now is 18:46.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.