HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   File size limit exceeded ? (http://www.howtoforge.com/forums/showthread.php?t=1678)

igorj 14th December 2005 12:15

File size limit exceeded ?
 
Hello everyone.
I must say that Im total newbie with ispconfig, but I like it already.

I recently installed ispconfig 2.0.6 on Debian 3.1 and I have a following problem with webalizer statistics.

For virtual hosts which have web.log file that is 2048M in size statistics is not working.
When I try to run webalizer manually I get error that said:

File size limit exceeded

What is wrong ?

Please help. Thanks in advance.

falko 14th December 2005 12:55

This is what I found:
http://www.madirish.net/tech.php?section=5&article=27
http://www.linuxquestions.org/questi...ad.php?t=32681
http://info.ccone.at/INFO/Mail-Archi.../msg00504.html
http://archives.postgresql.org/pgsql...3/msg00260.php

martinoc 17th December 2005 02:40

Quote:

Originally Posted by igorj
Hello everyone.
I must say that Im total newbie with ispconfig, but I like it already.

I recently installed ispconfig 2.0.6 on Debian 3.1 and I have a following problem with webalizer statistics.

For virtual hosts which have web.log file that is 2048M in size statistics is not working.
When I try to run webalizer manually I get error that said:

File size limit exceeded

What is wrong ?

Please help. Thanks in advance.

Hi,

I came accross this problem recently and I have the solution!
The default stock kernel that comes with Debian 3.1 is kernal-image....i386
this means that it will run on any x86 machine. However the options for LFS (Large File System) have not been enabled in this kernel .

Your choices are a)to compile a custom kernel or more likely for the newbie
b) download the kernel-image...i686
at the moment this is kernel-image-2.6.8-2-686

so just type:

Code:

apt-get install kernel-image-2.6.8-2-686
and then reboot. The problem should then be fixed.

Pana 16th March 2006 02:27

I have the exact same problem.... I'm running the 2.6.8-2-k7 kernel on debian sarge..

/etc/fstab/
----------------
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1
/dev/hda5 none swap sw 0 0


I've read through all the threads and searched google etc and haven't found a solution to fix this.... I read here: http://www.linuxquestions.org/questi...ad.php?t=32681 that this guys problem came from bastille's configuration. From what I can see bastille (well, the one supplied with ispconfig) doesn't have an effect on the filesystem... only firewall.

I've also check disk quotas... there are no limits set... including for www-data user:
Disk quotas for user www-data (uid 33):
Filesystem blocks quota limit grace files quota limit grace
/dev/hda1 14008588 0 0 105161 0 0


"ulimit -a" reports this
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
file size (blocks, -f) unlimited
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) unlimited
virtual memory (kbytes, -v) unlimited

so it doesn't appear to be a bash enforced limit.

Can anyone think of anything else?

falko 16th March 2006 11:41

Maybe it's really a problem with the kernel, as martinoc suggested. You could try to install another one.


All times are GMT +2. The time now is 20:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.