HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   SSH access for site user (http://www.howtoforge.com/forums/showthread.php?t=16465)

cic 24th October 2007 01:08

SSH access for site user
 
I'm attempting to give SSH access for a site user and am being extremely unsuccessful. I've created the site and placed a check mark next to Shell Access. Under User & Email, I created a user and placed a check mark next to Administrator and Shell Access. When I attempt to use Putty to access the site, I can enter the username but immediately after entering the password, Putty closes. What have I missed?

Thanks for any guidance!
Troy

till 24th October 2007 11:11

Please have a look at your syslog or auth.log for error messages from your SSH daemon.

cic 16th November 2007 03:46

It appears to accept the password because after I type in the password, I get a message "Last login date from blah, blah, blah... and then my putty session closes. Using the same username/password, I can login at the console just fine and using the admin username, I can login via putty from my remote location just fine. Do I need to add the website user to a file?

Troy

wpwood3 16th November 2007 06:32

Look at /etc/passwd
make sure the user has /bin/bash

cic 16th November 2007 20:48

Here's this users settings: :x:10002:10002::/var/www/web2/./:/bin/bash

falko 17th November 2007 09:37

Did you set up chrooted SSH?

cic 19th November 2007 03:52

No...and to be honest, I'm not sure how to do this? I just "playing" around with ISPConfig and I'm not an experienced linux person. Can you point me in the right direction?

falko 20th November 2007 14:21

Either set up chrooted SSH as shown here: http://www.howtoforge.com/chrooted_ssh_howto_debian
http://www.howtoforge.com/chroot_ssh_sftp_fedora7
or set $go_info["server"]["ssh_chroot"] to 0 in /home/admispconfig/ispconfig/lib/config.inc.php to not use chrooted SSH (much easier).


All times are GMT +2. The time now is 12:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.