HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Segmentation fault errors after BIND editing (http://www.howtoforge.com/forums/showthread.php?t=16385)

wxman 21st October 2007 17:05

Segmentation fault errors after BIND editing
 
Hi All,

It seems that I've botched up something on my new server. I had most of it working, and I was just tweaking the DNS settings. After I did a bind restart I saw my SMTP wasn't working. The errors were mainly showing that it couldn't get any updates from clamav. I did another restart of bind, and got:

Code:

root@server1:/home/tom# /etc/init.d/bind9 restart
 * Stopping domain name service...                                      [ ok ]
/etc/init.d/bind9: line 17:  5652 Segmentation fault      sleep 2
 * Starting domain name service...                                                                                                                          /etc/init.d/bind9: line 17:  5818 Segmentation fault      mkdir -p /var/run/bind                                                                            /run
/etc/init.d/bind9: line 17:  5822 Segmentation fault      chmod 775 /var/run/bin                                                                            d/run
                                                                        [ ok ]

I did some research, and found others saying that they had similar problems that were fixed by making the bind directory world readable. The permissions are set like this now:

Code:


root@server1:/var/run# ls -al
total 40
drwxr-xr-x 13 root  root    440 2007-10-21 06:25 .
drwxr-xr-x 14 root  root  4096 2007-10-03 20:17 ..
drwxr-xr-x  2 root  root    60 2007-10-21 06:25 apache2
-rw-r--r--  1 root  root      5 2007-10-21 06:25 apache2.pid
-rw-r--r--  1 root  root      5 2007-10-20 10:49 atd.pid
drwxr-xr-x  3 root  root    60 2007-10-20 10:49 bind
drwxr-xr-x  2 root  root    140 2007-10-21 06:25 console
drwxr-xr-x  4 daemon daemon  240 2007-10-20 10:49 courier
-rw-r--r--  1 root  root      5 2007-10-20 10:49 crond.pid
----------  1 root  root      0 2007-10-20 10:49 crond.reboot
drwxr-xr-x  2 klog  klog    100 2007-10-20 10:49 klogd
-rw-r--r--  1 root  root      5 2007-10-20 10:49 mdadm.pid
drwxr-xr-x  2 mysql  root    80 2007-10-20 10:49 mysqld
drwxr-xr-x  2 root  root    60 2007-10-21 10:12 network
drwxr-xr-x  2 root  root    80 2007-10-20 23:59 proftpd
-rw-r--r--  1 root  root      6 2007-10-20 23:59 proftpd.pid
drwx--x---  2 root  sasl    40 2007-10-20 10:49 saslauthd
drwxr-xr-x  2 root  root    40 2007-10-20 10:49 sshd
-rw-r--r--  1 root  root      5 2007-10-20 10:49 sshd.pid
drwx------  3 root  root    60 2007-10-20 15:36 sudo
-rw-r--r--  1 root  root      6 2007-10-21 06:47 syslogd.pid
-rw-rw-r--  1 root  utmp  4992 2007-10-21 10:48 utmp

root@server1:/var/run/bind# ls -al
total 0
drwxr-xr-x  3 root root  60 2007-10-20 10:49 .
drwxr-xr-x 13 root root 440 2007-10-21 06:25 ..
drwxrwxr-x  2 root bind  40 2007-10-20 22:13 run

Now if I try to use CHMOD on these directories, all I get is "Segmentation fault". The only other thing I did was use ISPConfig to add another domain to test with. Both of my test sites work when I try to access them through the web, I can still log into ISPConfig, and SSH just fine.
I just can't find what I messed up this time?

till 21st October 2007 18:28

Please set the permissions of the bind directories as described in the perfect setup guide for your linux distribution. Then have a look at your named.log or syslog if bind logs any errors.

Make sure that you did not add a primary domain record and a secondary domain record for the smae domain on your server as this will cause bind to fail.

wxman 21st October 2007 19:21

Hi Till

There aren't any bind errors in the syslog.

I know I don't have a primary and secondary record for the same domain.

When I set things up I used the perfect setup for a guide, and I set everything just as it said to do.

Things seem to be getting worse though. I can't log into ISPConfig now. All I get is a page of mysql errors. I tried to use SSH to /etc/init.d/mysql restart, and it gives me:

Code:

root@server1:/home/tom# /etc/init.d/mysql restart
Stopping MySQL database server: mysqld.
/etc/init.d/mysql[5523]: ERROR: The partition with /var/lib/mysql is too full!

Now I know that partition can't be full!

till 21st October 2007 19:56

Please post the output of:

df -h

did all the problems began after a restart? then the /var partition might be mounted read only.

wxman 21st October 2007 20:04

Quote:

Originally Posted by till
Please post the output of:

df -h

It comes back only as: Segmentation fault

Quote:

Originally Posted by till
did all the problems began after a restart?

To tell you the truth, I really can't say. I was doing edits on the named.conf file, and then after I thought I had the right setup, I did a restart. I then edited /root/ispconfig/isp/conf/named.conf.master with my new setup. After that I added a new web site using the ISPConfig interface to see if it works. I think it was then that things started to fall appart.


Quote:

Originally Posted by till
then the /var partition might be mounted read only.

How do I check that?

wxman 21st October 2007 20:16

I don't know if this helps, but I ran mount and it showed:

Code:

/dev/sda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
/sys on /sys type sysfs (rw)
varrun on /var/run type tmpfs (rw)
varlock on /var/lock type tmpfs (rw)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
devshm on /dev/shm type tmpfs (rw)


falko 22nd October 2007 14:07

You could try this: http://www.howtoforge.com/forums/sho...ight=fsck.ext3

wxman 22nd October 2007 15:55

I've never used the rescue system before. I assume it's the one I get to by rebooting with the CD in and choosing rescue?

I did that, and it said it couldn't access any of the hard drive partitions.

I'm trying a couple of different boot disks to see if I can access anything.

wxman 22nd October 2007 18:19

This is getting really fun!
I can't get any of my live cd versions to work. It looks like none like my SATA hard drive controller. Could that be part of the problem?

I know that if I watch the monitor as the server booted up, back when it worked, it showed a bunch of drive errors: ata2: translated ATA stat/err 0x51/20 to SCSI SK/ASC/ASCQ

I would like to try fsck, but I've never used it before, and the info about it on the web is not very helpful. I'm guessing I first need to be able to boot into something. I can get to the rescue section, but I can't get fsck to do anything there. It just keeps showing me it's help info. I'm also not to sure about how I need to mound the partition. I know I only have one on the servers drive.

till 23rd October 2007 09:08

You will have to be able to boot from a rescue system first, the partitions should not be mounted if you run fsck. If you have a ext3 filesystem for example, the fsck command will be something like:

fsck.ext3 /dev/hda

or

fsck.ext3 /dev/sda


All times are GMT +2. The time now is 06:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.