HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   istalled fine (Fedora core 4) but HTTPD problem (http://www.howtoforge.com/forums/showthread.php?t=1633)

edge 11th December 2005 16:19

istalled fine (Fedora core 4) but HTTPD problem
 
Hi all,

After reading and doing all the Perfect Setup Fedora Core 4, and the ISPConfig Installation Instructions I can now login to the ISPConfig interface on port 81.

However.. I can not get Apache (httpd) to start anymore..
Looking at the '/var/log/httpd/error.log' it is showing me this:
(13)Permission denied: httpd: could not open error log file /home/www/web1/log/error.log.
Unable to open logs


The directory is there, but the error.log file not!

Anyone here who might know what is set wrong?

Thank you...

falko 11th December 2005 22:14

Quote:

Originally Posted by edge
Hi all,

After reading and doing all the Perfect Setup Fedora Core 4, and the ISPConfig Installation Instructions I can now login to the ISPConfig interface on port 81.

However.. I can not get Apache (httpd) to start anymore..
Looking at the '/var/log/httpd/error.log' it is showing me this:
(13)Permission denied: httpd: could not open error log file /home/www/web1/log/error.log.
Unable to open logs


The directory is there, but the error.log file not!

Strange... I suggest that you create the error log manually (and check later for other web sites if the error still occurs...):

Code:

touch /home/www/web1/log/error.log
chmod 644 /home/www/web1/log/error.log

Then chown it:
Code:

chown web1_<admin>:web1 /home/www/web1/log/error.log
and restart Apache afterwards.

till 11th December 2005 22:52

Have you enabled the Fedora Security extensions or set an higher security level sa suggested in the howto? For me it looks like SE Linux or a similar extension is enabled.

edge 11th December 2005 23:24

I've just started installing all over again... Will let you know how I get on..

edge 12th December 2005 01:52

Quote:

Originally Posted by till
Have you enabled the Fedora Security extensions or set an higher security level sa suggested in the howto? For me it looks like SE Linux or a similar extension is enabled.

till, could you please quote/show the part about this in the howto?

I've done a clean install of Fedora and ISPConfig, but I'm still having problems starting httpd (service httpd start).. It's giving me a 'failed'

Problem now is (taken from /var/log/httpd/error_log)
Quote:

unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d' : Permission denied
Unable to open logs
The only info I can find about this is: http://www.howtoforge.com/forums/showthread.php?t=201

Quote:

you where correct the problem was SE linux

i now have disabled the SELinux httpd deamon.

don know if that is a proper or correct way to do.
<SElinux is somehow new to me>

so im open for any ideas to work around this problem and still enable the selinux httpd deamon.
I'm new to SELinux... How do I disabled it?

Thank you for any help!

falko 12th December 2005 10:24

Quote:

Originally Posted by edge
till, could you please quote/show the part about this in the howto?

It's the third image on http://www.howtoforge.com/perfect_se...dora_core_4_p2.

edge 12th December 2005 10:40

Quote:

Originally Posted by falko

Me an idiot..

Yes.. for sure I did not do that :-/

Thank you for pointing it out ...

Trying to fix the error now..

edge 12th December 2005 21:02

Got it al up and running..

The problem was the Fedora Security extensions...

Thanks for pointing it out to me

chris.sharman 14th December 2005 11:39

Turn off the security ? Why ? Doesn't it work ?
 
I certainly didn't turn off the SElinux stuff - my aim is to configure a secure web server, so I assumed I wanted at least default security (and SELinux is on by default).
I read the 'Perfect Setup' document, but it didn't explain why I should disable security, and I didn't want to, so I assumed (perhaps wrongly) that document wasn't for me.
Can anyone explain, or offer some guidance on the best way to set up a bombproof LAMP environment.

Thanks
Chris

till 14th December 2005 11:54

SELinux is on in Fedora, but not in other linux distributions. This does not mean that they are less ecure. SELinux makes some assumptions for a linux system that prevents ISPConfig on running.

If you want to have a really secure webserver i recommend not to install PHP or perl or any other scripting language for webpages as most hacks currently are done trough unsecure scripts. Then do not install any management software except an SSH server on a non common port and remove all compilers from your system.


All times are GMT +2. The time now is 14:38.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.