HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Email problem - all outgoing mail end up as spam (http://www.howtoforge.com/forums/showthread.php?t=16207)

haaglin 14th October 2007 17:18

Email problem - all outgoing mail end up as spam
 
Hi.
Sorry if this is not the right place to ask this question.

Im running ISPConfig on my server, and if i run a php script to mail someone, it ends up as spam, or sometimes it wont even make it to the spam box. Gmail allways recieve the email (as spam).

I dont have a dns server, so i use http://www.domainnameshop.com as dns provider. This is a line from the details of the recieved email:

Quote:

Received-SPF: neutral (google.com: *.*.*.* is neither permitted nor denied by best guess record for domain of www-data@*.*.*) client-ip=*.*.*.*;
Authentication-Results: mx.google.com; spf=neutral (google.com: domain of noreply@domain.com does not designate *.*.*.* as permitted sender)

####
Server ip is replaced with *.*.*.*
FROM email is replaced with noreply@domain.com
####
What does that mean?

Please help me fix this.

falko 15th October 2007 09:28

Make sure that you have an SPF record for your domain.
Also, please check if your server is blacklisted: http://www.mxtoolbox.com/blacklists.aspx

haaglin 15th October 2007 10:55

My server is not blacklisted. I have never added an spf record before, so tell me if this is wrong. Its still not working.

This is from the zone file:

Code:

mydomain.com.        3600        IN        TXT        "v=spf1 a ~all"
One other thing, where do i change the smtp.mail and Return-path address in the mail? The address entered there is wrong

falko 16th October 2007 11:24

Quote:

Originally Posted by haaglin
My server is not blacklisted. I have never added an spf record before, so tell me if this is wrong. Its still not working.

This is from the zone file:

Code:

mydomain.com.        3600        IN        TXT        "v=spf1 a ~all"

You can use this wizard to check your SPF record: http://old.openspf.org/wizard.html

Quote:

Originally Posted by haaglin
One other thing, where do i change the smtp.mail and Return-path address in the mail? The address entered there is wrong

You must set the correct sender address in your email client.

haaglin 16th October 2007 16:25

The spf record seems to have worked for gmail. Thanks!

However, there is still a domain that wont recieve at all.

I have a domain (www.mydomain.com) hosted by someone else, but i have som subdomains of that domain (sub.mydomain.com) hosted by my own server running ispconfig.

The email is not served by me, but if i try to send an email to user@mydomain.com from my server, it never gets there.
Does my server stop outgoing emails if i hosts a subdomain of the domain the email address i send to?

Thanks.

till 16th October 2007 17:00

Please have a look into the mail log, do you get any errors when you send a email to this domain?

haaglin 16th October 2007 17:09

Yes! Found the emails. The server does stop the email from going out to the mailserver, and puts them in a mailbox of the administrator of the subdomain. Under options, i have selected "External mailserver" as mailserver, but still no go.. so i removed every entry of the domain from /etc/postfix/local-host-name and /etc/postfix/virtusertable but still they are getting into the mailbox of the administrator. (I did restart both ispconfig and postfix after the changes)

Any advice?

till 16th October 2007 17:30

You must set the website to external mailserver AND the co-domain.

haaglin 16th October 2007 17:35

Wee!! That did the trick! Thanks a lot :D


All times are GMT +2. The time now is 22:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.