HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Remoting Framework / xml instalation issue (http://www.howtoforge.com/forums/showthread.php?t=16007)

gauthier 5th October 2007 18:29

Remoting Framework / xml instalation issue
 
Hi, please forgive my unknowledge.

I installed ISPconfig v2.2.17 on centos4.4 following "perfect setup" instructions. I tried to make my best, ISPconfig is now running fine (this is a great control panel), thanks to members and administradors of this forum.

I have now a problem with Remoting Framework.
I installed the remoting extension fine, and created remote user.
Then I tried the test.php example, it do not work (blank page).

Went to php.ini: and "display_errors On".
I have some irrevelant "notice", but no "warnings".
I edit soap.lib.php and add the following "echo":

$return = $this->send($soapmsg,$soapAction,$this->timeout);
echo 'return='.gettype($return).'<br>';

It displays:"return=NULL", ok there is something wrong related to the send function.

I add the following "echo" in the "send" function:

$response = $http->sendHTTPS($msg,$timeout);
echo $response.'<br>';

It displays:

Fatal error: Call to undefined function xml_parser_create() in /home/admispconfig/ispconfig/lib/classes/ispconfig_soap.obj.php on line 3256

Ok. I have got it, but how shall I fix it?

I checked xml installation.

phpinfo() displays:
XML Support active
XML Namespace Support active
EXPAT Version expat_1.95.7

Fine no?

Tried to download and install:
http://www.ispconfig.org/downloads/I....1.2xml.tar.gz
->This link no longer runs, I do not know if it is still necesary.

Tried:
cpan>install XML::Parser
->displays "XML::Parser is up to date"

I suppected something wrong with my "perfect" centos4.4 setup.

I redo some installation steps and I find this:
In instruction "yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel", php-xmlrpc package is found and installed but php-xml package is not found.

yum install php-xml displays "Cannot find a package matching xml-php"

Could you please tell me if you have any idea of what I am doing wrong ? Is this an xml installation issue ? May I change my php.ini to add any extension ?

Thanks a lot.

gauthier 6th October 2007 00:33

Where is ISPConfig-2.3.0-dev.tar.gz ????
 
Ok, it seems the problem is I did not enable XML for ISPconfig.

I suppose I have to upgrade to a development version ...

Thanks

falko 6th October 2007 14:23

You an get 2.3.3-dev from here: http://prdownloads.sourceforge.net/i...ar.gz?download

gauthier 7th October 2007 23:21

Thankyou Falko.

I read carefuly your warnings about development version, and I am afraid I may not be able to repair my ispconfig instalation if any error occurs.

I do not know excatly how ispconfig is being improved, but I suppose I have another solution:

Wait for a new stable ISPconfig version in which XML is enabled ... :cool:

I am right ? Have you got any idea of how long I may wait ? :rolleyes:

Thanks.

till 8th October 2007 11:50

Please have a look here on how to install the ISPConfig stable version with remoting framework:

http://www.howtoforge.com/forums/showthread.php?t=11873

A stable version with remoting framework wil do the same as descrinbed there, so there is no benefit to wait for a new version.

gauthier 8th October 2007 14:50

This is EXACTLY what I was looking for.

Thankyou very much to Till.

For if someone read us and have done the same updates tu work with remoting framework, I would just point out that after rerrunning the ./setup (with xml enabled) the remote users are removed and the "add" remote user tool is disabled. It is necesary to reinstall the remote extension and then create a remote user.

All runs fine.

gauthier 9th October 2007 00:18

Well.... if I try to create a new site with remote framework I have some issues.

I fix the first issue using your thread http://www.howtoforge.com/forums/showthread.php?t=15509 (I return a string instead of soap_faults in /home/admispconfig/web/remote/index.php).

Now I have the following problem: site seems to be created (I can see it within ispconfig panel) but it does not actualy work: var/www/webx is not created, neither var/www/www.mysite.com

debug shows:
-------------------
.....
soap_transport_http: port = 81
soap_transport_http: path = /remote/index.php
soap_transport_http: entered sendHTTPS() with data of length: 1882
soap_transport_http: found proper separation of headers and document
soap_transport_http: cleaned data, stringlen: 183

soapclient: got response:
Fatal error: Call to a member function myGroups() on a non-object in /home/admispconfig/ispconfig/lib/classes/ispconfig_isp_web.lib.php on line 394
.....
-------------------

I would be grateful if someone can help me with this.

till 9th October 2007 10:06

I Added this to the bugtracker, it looks as if one of the fixes in ISPConfig 2.2.17 has broken the remoting framework.

As a temporary workaround, comment out the lines 394 - 404 from the file /home/admispconfig/ispconfig/lib/classes/ispconfig_isp_web.lib.php


All times are GMT +2. The time now is 12:49.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.