HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Mysql assignation to a new website (http://www.howtoforge.com/forums/showthread.php?t=1591)

jeanjacquesjeanjacques 8th December 2005 13:09

Mysql assignation to a new website
 
Hello,
When i try to create a website using the admin account i have this error message:
"You cannot assign shell access to this website.
You cannot assign MySQL databases to this website"
I tried to look for informations inside the forum but i've found nothing.
Is there someone who knos how could i fix this ?

Best regards,

Jean-Jacques

falko 8th December 2005 16:56

Are you sure you tried this as admin and not as a reseller? Please double-check.

st2xo 30th January 2006 15:31

Hi - I have the same problem ...

Just installed the default ("perfect setup") ispconfig installation with no problems, all looks fine. I did not have changed any settings, except to add a reseller and a client account (reseller added as admin, client added as reseller)
The only difference from the default setup I made was the mysql databasename/prefix: I used ISPCONFIG (default was "ispconfigdb" I think)

the result after adding a web in "site management" is
"You cannot assign MySQL databases to this website."
"Sie können diesem Web keine MySQL-Datenbanken zuordnen." (same in german)

This occurs as admin and as reseller and with a web-template or with "individual settings", or with "-1" allowed databases or with a number, eg. 10
So its not possible to create a new web with databases (one or more)

I switched from admin to reseller and backward by logging out and closing the browser. So all session-data should have been deleted.

Does anybody have a hint for me? Many thanks in advance!

And - last but not least - with my first posting I want to thank for providing ISPConfig! Not only ISPcofig for itself must be great (I could not try it until now :-), even the documentation, installation at last this support forum and the community is outstanding of many projects I know!

till 30th January 2006 17:38

The error might occur if you have not set and saved the limits of the reseller.

Please login as admin, open the reseller settings of the reseller you are talking about, go to the limits tab, check if all limits are ok and the save the reseller again.

Then try again to add the website.

st2xo 30th January 2006 17:53

Yes, that´s it!

The "number of databases" setting was correct with "-1" or a number.
But the checkbox "mysql" wasnt checked and I havent seen it :eek:

I could sware it was checked at first time - eyes and brain are getting older. Thank you!


All times are GMT +2. The time now is 13:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.