HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   how to change the default port 81 ? (http://www.howtoforge.com/forums/showthread.php?t=157)

Jugernaut 30th July 2005 15:30

how to change the default port 81 ?
 
hi,

first i must say ispconfig is a very great piece of work !
i'm just another noob on linux, spend a lot of time with bad manuals or how-tos... to bring my dedicated server to work without all that visas and confixx crap.

since i found the how-to for SuSE 9.3 from falko the things get better day by day and i guess i'm now also infected with the linux virus ;)

i wonder how i can change the default port 81 of ispconfig into another one after installation ?
maybe i'm just blind but i don't find any informations on that...
hope someone can help - thx

cheers

till 30th July 2005 15:37

Quote:

Originally Posted by Jugernaut
hi,

first i must say ispconfig is a very great piece of work !
i'm just another noob on linux, spend a lot of time with bad manuals or how-tos... to bring my dedicated server to work without all that visas and confixx crap.

since i found the how-to for SuSE 9.3 from falko the things get better day by day and i guess i'm now also infected with the linux virus ;)

i wonder how i can change the default port 81 of ispconfig into another one after installation ?
maybe i'm just blind but i don't find any informations on that...
hope someone can help - thx

cheers


After installation please do the following:

Stop the ISPConfig system: /etc/rc.d/init.d/ispconfig_server stop (RedHat/Mandrake) or /etc/init.d/ispconfig_server stop (SuSE).

Open the file /home/admispconfig/ispconfig/lib/config.inc.php, look for the variable

$go_info["server"]["server_url"]

and change port 81 to your new port.

Afterwards, edit the file /root/ispconfig/httpd/conf/httpd.conf and replace all occurrences of port 81 with your new port number. Then restart the
ISPConfig system: /etc/rc.d/init.d/ispconfig_server start (RedHat/Mandrake) or /etc/init.d/ispconfig_server start (SuSE).

Dont forget to activate the new port in your firewall settings!

Jugernaut 30th July 2005 15:59

damn - 7 minutes to answer, thats lighting fast :eek:

THX bud, seems quite easy... :)

cheers

falko 30th July 2005 18:39

One thing to add: Don't use port 80 or 443 for ISPConfig or any other port that's already in use on your system... ;)

timbo 12th November 2005 12:21

Of course, A Linux newb screws up his new ispconfig install by:
 
Adding the frigging external ip address to the iplist in ISPConfig.

Here's one for you Falko, How can I change the IPList back to default FROM OUTSIDE ISPConfig? Since I changed it, I can't access it anymore from https://host.example.com:81.

I only got to look at it for like five mins :(

thx tb

till 12th November 2005 13:48

Do you need an answer to your question or an answer from falko ;)

Open the file /home/admispconfig/ispconfig/lib/config.inc.php and cahnge the line:

$go_info["server"]["network_config"] = 1;

to:

$go_info["server"]["network_config"] = 0;

Then restart your server and login to the ISPConfig controlpanel to change the IP's in the IPList.

General remark: Please make a new thread in the Forum if your question is not related to the topic of the thread.

timbo 12th November 2005 17:21

Oops, sorry and sorry. I looked in so many forums, I forgot which one I was in.

Any answer would do, I was just expecting Falko to find it first. :rolleyes:

Actually it is sort of related (now) because my system keeps telling me that:
/home/admispconfig/ispconfig/lib/config.inc.php is a "new" file.

Could that file have been created in another directory?

Thanks for the response, I'll do better next time.

dumbo

till 12th November 2005 17:26

No, if ISPConfig has been installed correctly the file must be in zhis location.

Is thsi your first logib in the ISPConfig admin interface?

Jcorrea920 3rd November 2006 17:33

doesn't work on port 82
 
Please see http://www.howtoforge.com/forums/sho...ed=1#post46789
and http://www.howtoforge.com/forums/showthread.php?t=7902

Already read this thread and followed Till instructions, but still doesn't work. Help is greatly apprecitated. Thanks in advanced.

Jcorrea920 3rd November 2006 21:33

Issue Solved: Control Panel Malfunction
 
Please see: http://www.howtoforge.com/forums/sho...ed=1#post46819


All times are GMT +2. The time now is 05:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.