HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Need help with Postfix Install (http://www.howtoforge.com/forums/showthread.php?t=15453)

joelee 10th September 2007 23:32

Need help with Postfix Install
 
Hi All,

I am going through the installation of postfix as per the following how-to:
http://howtoforge.com/virtual_users_...ix_debian_etch

The install seems to have been going fine up until I got to step9 to install amavisd-new, SpamAssassin, And ClamAV....

Below is the link to the page:
http://howtoforge.com/virtual_users_...debian_etch_p4

After running the following command:
Code:

apt-get install amavisd-new spamassassin clamav clamav-daemon zoo unzip bzip2 unzoo libnet-ph-perl libnet-snpp-perl libnet-telnet-perl nomarch lzop pax
I get the following errors for the above command: (Truncated)
Code:

Starting amavisd: No listen sockets or ports specified
(failed).

invoke-rc.d: initscript amavis, action "start" failed.
dpkg: error processing amavisd-new (--configure):
 subprocess post-installation script returned error exit status 1
Setting up unzoo (4.4-5) ...
Errors were encountered while processing:
 amavisd-new
E: Sub-process /usr/bin/dpkg returned an error code (1)

FYI, durring the install of the how-to I captured everything to a file. Going through the captured file I have noticed the following errors before the one reported above. Below are snippets of errors encountered during the install.

Error below was generated after running command step2
Code:

WARNING: /etc/aliases exists, but does not have a root alias.
Error below was generated after running command step2
Code:

Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . ..
Checking for corrupt, not cleanly closed and upgrade needing tables..
Setting up courier-base (0.53.3-5) ...
Setting up courier-pop (0.53.3-5) ...

Error noticed during step3 (Apply The Quota Patch To Postfix)
Code:

mx1:/usr/src# apt-get source postfix
Reading package lists... Done
Building dependency tree... Done
Need to get 2950kB of source archives.
Get:1 http://ftp.se.debian.org etch/main postfix 2.3.8-2 (dsc) [897B]
Get:2 http://ftp.se.debian.org etch/main postfix 2.3.8-2 (tar) [2788kB]
Get:3 http://ftp.se.debian.org etch/main postfix 2.3.8-2 (diff) [161kB]                                                           
Fetched 2950kB in 11s (250kB/s)                                                                                                   
gpg: can't open `/gnupg/options.skel': No such file or directory
gpg: Signature made Tue Mar 13 04:46:40 2007 UTC using DSA key ID
0A0AC927
gpg: Can't check signature: public key not found
dpkg-source: extracting postfix in postfix-2.3.8
dpkg-source: unpacking postfix_2.3.8.orig.tar.gz
dpkg-source: applying ./postfix_2.3.8-2.diff.gz
mx1:/usr/src#

* I want to know what to do about the above gpg errors:


Noticed the "warning" errors below after running command from step3
Code:

mx1:/usr/src/postfix-2.3.8# dpkg-buildpackage

.....Error Snippet....
 dpkg-source -b postfix-2.3.8
dpkg-source: building postfix using existing postfix_2.3.8.orig.tar.gz
dpkg-source: building postfix in postfix_2.3.8-2.diff.gz
dpkg-source: warning: executable mode 0755 of `debian/patches/10man-names.dpatch' will not be represented in diff
dpkg-source: warning: executable mode 0755 of `debian/patches/10cyrus.dpatch' will not be represented in diff
dpkg-source: warning: executable mode 0755 of `debian/patches/10tls.dpatch' will not be represented in diff

Noticed the "Wmissing" messages below after running command from step3
nott sure if there are any concerns/issues?
Code:

........SNIPPET....
make: Entering directory `/usr/src/postfix-2.3.8/src/util'
gcc -Wmissing-prototypes -Wformat -DDEBIAN -DMAX_DYNAMIC_MAPS -DHAS_PCRE -DHAS_LDAP -DHAS_CDB -DHAS_MYSQL -I/usr/include/mysql -DHAS_PGSQL -I/usr/include/postgresql -DHAS_SSL -I/usr/include/openssl -DUSE_SASL_AUTH -I/usr/include/sasl -DUSE_CYRUS_SASL -DUSE_TLS -fPIC  -O2 -I. -DLINUX2 -c alldig.c
gcc -Wmissing-prototypes -Wformat -DDEBIAN -DMAX_DYNAMIC_MAPS -DHAS_PCRE -DHAS_LDAP -DHAS_CDB -DHAS_MYSQL -I/usr/include/mysql -DHAS_PGSQL -I/usr/include/postgresql -DHAS_SSL -I/usr/include/openssl -DUSE_SASL_AUTH -I/usr/include/sasl -DUSE_CYRUS_SASL -DUSE_TLS -fPIC  -O2 -I. -DLINUX2 -c allprint.c

I would appreciate anyones help about the error messages above...

Joe

falko 11th September 2007 18:09

Quote:

Originally Posted by joelee
Error below was generated after running command step2
Code:

WARNING: /etc/aliases exists, but does not have a root alias.

Did you modify /etc/aliases as shown in chapter 8 on http://howtoforge.com/virtual_users_...debian_etch_p3 ?

joelee 12th September 2007 01:05

Falko, yes I did apply the aliases as required... Below is what I did for the that step - I just changed below to my domain name...
[...]
postmaster: root
root: postmaster@MyDomain.com
[...] Joe

joelee 12th September 2007 17:16

Falko, per my last reply below, I was wondering if I need to install gcc. I notice the gcc related errors/warning messages as shown in my output. Also, I am wondering about the error msg referring to gpg. Would I need gpg installed?

Joe

falko 12th September 2007 20:56

Quote:

Originally Posted by joelee
Falko, per my last reply below, I was wondering if I need to install gcc. I notice the gcc related errors/warning messages as shown in my output.

Install build-essential: apt-get install build-essential
It contains everything you need to compile things from the sources.
Quote:

Originally Posted by joelee
Also, I am wondering about the error msg referring to gpg. Would I need gpg installed?

You can ignore these warnings.

joelee 13th September 2007 21:26

Falko, I tried to do a re-install of the postfix and hit the same issue. As before, build-essential is installed... Again, I've hit this error message below
Code:

mx1:/etc/postfix# adduser clamav amavis
Adding user `clamav' to group `amavis' ...
Done.
mx1:/etc/postfix# /etc/init.d/amavis restart
Stopping amavisd: (not running).
Starting amavisd: No listen sockets or ports specified
(failed).

mx1:/etc/postfix#

I am not sure why I getting the above error - Any thoughtts/suggestions?


Joe

falko 14th September 2007 18:11

I think there's a problem with your amavisd configuration. Please compare it to the one from the tutorial. Maybe you accidentally deleted parts of the configuration?


All times are GMT +2. The time now is 08:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.