HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   procmail supposed to be in main.cf? (http://www.howtoforge.com/forums/showthread.php?t=1533)

Smitty 4th December 2005 22:18

procmail supposed to be in main.cf?
 
Is procmail supposed to be picked up by the postfix installs, following The Perfect Setup (on debian sarge 3.1 net install) in defining the "mailbox_command =" into Postfix's main.cf? I notice from the view window of the tutorial that "mailbox_command" in the main.cf looks like this "mailbox_command = procmail -a "$EXTENSION". Yet, once I'm done with the Perfect Setup on postfix, mine mailbox_command is not set to that.

Is this a manual setting which I should make for the Perfect Setup to prep for ISPConfig installation, on the mailbox_command variable, or have I done something wrong with the installs on Perfect Setup. Or, do I have to do something more elaborate installing/defining procmail recpies as they would be picked up for insertion into this Postfix install?

Is this just a tutorial omission where defining the "mailbox_command" wasn't/hasn't been provided for in the instructions?

After a full clean 2nd install of debian, and ISPConfig on The Perfect Setup, following everything to the letter, I notice where my 2nd install doesn't produce the necessary definition of this mailbox_command, again.

From my first install, and noticing this omission, I could send email's from the webmail interface all day long, but any emails being sent to a ISPConfig user would be delivered, but go to never-never land.

... and suggestions, or corrections, with this "mailbox_command" definition in Postfix's main.cf would be greatly appreciated.

Do I have to reinstall debian, and/or ISPConfig again?

... in advance, thanks.

Smitty

till 4th December 2005 22:29

There is no error in the howto. If you use ipop3d as pop3 daemon, the mailbox command shall look like this:

mailbox_command = procmail -a "$EXTENSION

Have you installed courier-pop and courier-imap as described later in the howto (end of page 5)? Then the mailbox command must be empty:

mailbox =

For courier you will also have to switch to maildir delivery in ISPConfig under Management > Server > Settings on the mail tab. Otherwise you mail gets delivered to mbox files and you cant fetch them with your mailclient.

falko 4th December 2005 23:04

Please post the output of
Code:

postconf -d | grep -i "mailbox_command"
Also make sure, you enable/disable Maildir according to your POP3 server (as Till posted above).

Do you see anything in /var/log/mail.log when a mail arrives?

Smitty 4th December 2005 23:45

Output of: postconf -d | grep -i "mailbox_command"

mailbox_command =
mailbox_command_maps =

Let's see.... Hmm... I have courier-pop and courier-imap installed, it looks like. In addition to the "mailbox_command =", I also have a "home_mailbox = Maildir/" definition in my main.cf file.

Would the firewall definitions for port 993 and port 995, for courier, have automatically been picked up by the ISPConfig install, as well? Checking the firewall settings in ISPConfig, I don't have any firewall provisions allowing for port 993 and port 995 connections.

I have checked the "Maildir" box in the "mail" config screen of ISPConfig.

I just finished this install a little while, ago and haven't had a chance to email test it, yet. I hope to do that shortly, here. Once tested, I'll post any mail.lob errors/questions, back here.

... in advance, thanks.

Smitty

falko 5th December 2005 10:10

Quote:

Originally Posted by Smitty
Output of: postconf -d | grep -i "mailbox_command"

mailbox_command =
mailbox_command_maps =

Let's see.... Hmm... I have courier-pop and courier-imap installed, it looks like. In addition to the "mailbox_command =", I also have a "home_mailbox = Maildir/" definition in my main.cf file.

I think you did this:
Code:

postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart

as described on http://www.howtoforge.com/perfect_setup_debian_sarge_p4, so everything's fine.:)

Quote:

Originally Posted by Smitty
Would the firewall definitions for port 993 and port 995, for courier, have automatically been picked up by the ISPConfig install, as well? Checking the firewall settings in ISPConfig, I don't have any firewall provisions allowing for port 993 and port 995 connections.

No, you have to shut down the firewall on the ISPConfig box and start the ISPConfig firewall, and define rules for the ports 993 and 995. That's all.


All times are GMT +2. The time now is 13:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.