HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   SSL and Google Checkout (http://www.howtoforge.com/forums/showthread.php?t=15023)

phreeman 24th August 2007 00:45

SSL and Google Checkout
 
I'm trying to configure the Google checkout feature to a ZenCart e-commerce site running on suse10.2 configured with ISPConfig. I'm having a problem with the security certificate. I tried to follow the suggestions in the thread:

http://www.howtoforge.net/forums/showthread.php?t=1854

but still no joy. the site is working fine on both IE and firefox but google is rejecting the certificate.

Running: # openssl s_client -connect www.mysite.com:443 -showcerts < /dev/null

shows:

CONNECTED(00000003)
depth=3 /L=ValiCert Validation Network/O=ValiCert, Inc./OU=ValiCert Class 2 Policy Validation Authority/CN=http://www.valicert.com//emailAddress=info@valicert.com
verify error:num=19:self signed certificate in certificate chain
verify return:0
---
Certificate chain
0 s:/O=www.mysite.com/OU=Domain Control Validated/CN=www.mysite.com
i:/C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./OU=http://certificates.godaddy.com/repository/CN=Go Daddy Secure Certification Authority/serialNumber=xxxxxxxx
-----BEGIN CERTIFICATE-----
etc.

(changed the domain and xx'd out the serial number)

I've added the httpd directive suggested by mjrpes (in the reference post, page 3) for the intermediate certificate and copied the .crt file to the /web2/ssl directory. I then restarted apache.
I then added my site certificate using the control panel and again restarted apache.

I trying to get a clean SSL chain so Google can properly call-back to my shopping cart. Any idea what I'm doing wrong in setting up the godaddy certificates? Your help is greatly appreciated.

till 24th August 2007 10:07

You must upload the SSL cert in ISPConfig by copyibg it to the correct field on the SSL tab and the select save as action and not copy it to the ssl cert directory manually.

phreeman 25th August 2007 17:45

I thought I had done just that. I re-tried loading the intermediate certificate, set the hpptd directive, restarted apache. I then re-enterd the SSL cert through the ISP config control panel SSL tab and saved. Restarted apache and the SSL is now working through Google checkout. I'm still receiving the same response for the openssl command but it doesn't seem to affect the https transfers.

Thanks much for the help.


All times are GMT +2. The time now is 02:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.