HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Question regarding PHP setup in Ubuntu 6.06 LAMP install Howto (http://www.howtoforge.com/forums/showthread.php?t=14980)

FXT 22nd August 2007 11:14

Question regarding PHP setup in Ubuntu 6.06 LAMP install Howto
 
I've been using your howto to set up a LAMP server for testing purposes and learning the ropes.
In the step outlining the PHP 5 setup you tell the admin to:

Code:

apt-get install autoconf automake1.4 autotools-dev libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php-pear php5-ldap php5-mhash php5-mysql php5-mysqli php5-snmp php5-sqlite php5-xmlrpc php5-xsl php5-imap php5-mcrypt php5-pspell
In an earlier chapter you recommend running:

Code:

apt-get install binutils cpp cpp-4.0 fetchmail flex gcc gcc-4.0 libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev g++
Is the repeated install of autotools-dev, automake1.4 and autoconf necessary?
If so, why automake 1.4 after installing 1.9 at first?

I'm curious, as I'd like to be able to explain why I'm following your howto to interested parties.

Thank you.

falko 23rd August 2007 19:53

Quote:

Originally Posted by FXT
Is the repeated install of autotools-dev, automake1.4 and autoconf necessary?

No (must have been an accidental slip...). On the other side, it doesn't hurt...


All times are GMT +2. The time now is 15:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.