HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   User Add/Delete and FTP login problem. (http://www.howtoforge.com/forums/showthread.php?t=14969)

clabrown 22nd August 2007 00:54

User Add/Delete and FTP login problem.
 
I setup a client, and a client website. An Admin for the client and an admin user for the site. I have been unable to connect to any of the user name / password combinations I entered for the client / site to use FTP to add content to the site. I am able to connect with the Web_FTP function, but it only allows a single file transfer at a time and most websited are actually made with more that one file. File by file transfer is tedious.

I've been using both command line ftp and Firefox/FireFTP for testing.

next.

I misspelled the website Admin user when I entered the name, so I used the delete function. That user no longer shows up in the list in ISPConfig, but when I try to re-add the Site Admin with the correct spelling ISPConfig tells me that the email address is already used by another user. and won't let me add it.

When I look at the password list outside of ISPConfig it appears that the user that I deleted inside of ISPConfig, and that no longer shows up inside of ISPConfig, does in fact still exist on the machine. So for user management, how am I supposed to handle this? Apparently ISPConfig didn't really delete the user when I used it's delete function.

Any help would be appreciated

Thanks, Cla.

till 22nd August 2007 09:14

Please empty the recycle bin.

clabrown 22nd August 2007 15:35

Thanks Till:

Emptying the Recycle Bin allowed me to re-enter the user with the correct spelling, and also removed the user from the machine's "linux users".

Another question about ISPConfig users, I'd like to know if my understanding is correct.:

When I Setup the Client, I created an administrator user under ISP Manager > ISP Client > Login Data.

This "Client Admin User" did not seem to create a "real linux user", am I understanding this correctly that this is user "internal" to ISPConfig?

When I Setup the Client's Site, I created a site user under ISP Manager > ISP Site > User & Email, with the Admin box checked.

This "Site Admin User" does create a "real linux user".

The Client Admin can login to the ISPConfig control pannel on port 81, but can not connect to the site with FTP.

The Site Admin can not login to the ISPConfig control pannel, but can connect to the site with FTP.

Thanks again, Cla.

falko 23rd August 2007 19:12

Quote:

Originally Posted by clabrown
This "Client Admin User" did not seem to create a "real linux user", am I understanding this correctly that this is user "internal" to ISPConfig?

Right.

Quote:

Originally Posted by clabrown
This "Site Admin User" does create a "real linux user".

Right.

Quote:

Originally Posted by clabrown
The Client Admin can login to the ISPConfig control pannel on port 81, but can not connect to the site with FTP.

Correct.

Quote:

Originally Posted by clabrown
The Site Admin can not login to the ISPConfig control pannel, but can connect to the site with FTP.

Yes.


All times are GMT +2. The time now is 03:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.