HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Newbie Questions Abound...FTP...Firewall....???? (http://www.howtoforge.com/forums/showthread.php?t=14835)

xelf 17th August 2007 17:35

Newbie Questions Abound...FTP...Firewall....????
 
Hi, new to linux and just ran through the How to install for SUSE.

Basically installed linuxSUSE on old machine hear at work...Primarily to use as ftp but did want to have the other functions of mysql, php, mailserver....ect....
We run the machine on a static ip but during setup called it....server1.ourname(no .com)

I had orginally setup ispconfig then too but realized or assumed could not be usefull since we are not having an actual mywebsitename.com set up to route to the ip address. Then did a uninstall of ispconfig.

Also the machine sits behind an internal firewall/router on our network....It is given an internal ip address...It is also assigned an external IP on the router to forward to the internal address...just like all our other machines...

I had done an orginal install before finding howto...and created a simple user id to work with ftp. I was able to use filezilla to ftp both using the machines internal ip address and external.

Then I found howto...and did a complete re-install of linux SUse, install of ispconfig...did the unintstall of ispconfig....

Then just made a simple user id to ftp with....Now I'm only able to ftp via the internal ip and cannot ftp via the external address.

I do know that we have certain ports turned off and I do know the port#'s that are available that are open.

Does ispconfig turn on some other firewall that may be blocking??? or Only allowing certain ports for ftp???

How can I setup a simple ftp correctly??? We have several clients for our company and want to give each seperate logins and see only their folders....We don't want them to be able to login to the root/box id ofcourse...I want to be able to create new ones easily for new clients and manage their use ofcourse.

And ofcourse I want to be able to use other linux functions for using scripts and db ect.... for my company's own purposes..

Also is there a free controll panel that will work off of IP only and not full webaddress name???We may want to create virtual websites/logins for clients as well but without the need for regular urls...something like http://ipAddressOfSever/clientname ex http://123.123.123.1/client1

Thanks...Great site btw:)

xelf

falko 18th August 2007 13:18

Quote:

Originally Posted by xelf
Then I found howto...and did a complete re-install of linux SUse, install of ispconfig...did the unintstall of ispconfig....

Then just made a simple user id to ftp with....Now I'm only able to ftp via the internal ip and cannot ftp via the external address.

I do know that we have certain ports turned off and I do know the port#'s that are available that are open.

Does ispconfig turn on some other firewall that may be blocking??? or Only allowing certain ports for ftp???

Have you tried both active and passive transfers in your FTP client?
Did you disable AppArmor on SuSE?
The ISPConfig firewall isn't enabled by default. What's the output of
Code:

iptables -L
?

xelf 22nd August 2007 23:39

Sorry about delay response work been busy...

Ok, did a fresh install and ran through the perfect setup 10.1 again...I did not install ISPconfig....Still having same issue...If I ftp using root or admin with our internal IP it logs in no problem...Using our external IP id doesn't connect...Though I can ping the external ip no problem(disconnect cable to confirm no longer get it).

AppArmor is disabled

iptables -L output
Code:

server1:/tmp # iptables -L
Chain INPUT (policy ACCEPT)
target    prot opt source              destination

Chain FORWARD (policy ACCEPT)
target    prot opt source              destination

Chain OUTPUT (policy ACCEPT)
target    prot opt source              destination
server1:/tmp # iptables -L
Chain INPUT (policy ACCEPT)
target    prot opt source              destination

Chain FORWARD (policy ACCEPT)
target    prot opt source              destination

Chain OUTPUT (policy ACCEPT)
target    prot opt source              destination
server1:/tmp #

xelf

falko 23rd August 2007 20:40

Quote:

Originally Posted by xelf
Using our external IP id doesn't connect...

You must tell your router to forward port 21 to your server.


All times are GMT +2. The time now is 02:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.