HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ispconfig change remote mailserver by itself (http://www.howtoforge.com/forums/showthread.php?t=14813)

spazio 16th August 2007 22:20

ispconfig change remote mailserver by itself
 
The version installed is 2.3.1. on a debian box. I know i just realised that it's the dev version. First thing first, is there a way to upgrate to the production version 2.2.15 or is it best to stick to 2.3.2-dev?

The serveur changed all domain from local mailserver to remote mailserver by itself last night! The change was in the options of the site and in the domain alias as well. The result being the removal of all informations in the 2 following files.
/etc/postfix/virtualusertable and
/etc/postfix/local-host-names

Naturally, the effect of those changes being the reject of all incomming mail:(

Any idea of what happened? And is there a way to prevent this in the futur?

Thanks in advance for anyhelp...

till 16th August 2007 22:58

Quote:

The version installed is 2.3.1. on a debian box. I know i just realised that it's the dev version. First thing first, is there a way to upgrate to the production version 2.2.15 or is it best to stick to 2.3.2-dev?
You can not downgrade as the the database structures are not downwards compatible.

Quote:

The serveur changed all domain from local mailserver to remote mailserver by itself last night! The change was in the options of the site and in the domain alias as well. The result being the removal of all informations in the 2 following files.
/etc/postfix/virtualusertable and
/etc/postfix/local-host-names
This happens if the domain has no valid MX record in DNS pointing to your server. To fix this, create a MX record that point to your server.

Or you disable this security function in ISPConfig under management > server > settings on the mail tab.

jnsc 16th August 2007 23:01

This is do to a check of the MX int the dev version. If the MX of the domain is not set to the server, it automatically sets the domain to an external mail server. You can deactivate this behavior, but I don't recall the exact menu, and I don't have a dev server here actually, so you will have to search :)

[Edit]
Or just do what Till told you
[/Edit]


All times are GMT +2. The time now is 18:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.